Project

General

Profile

Bug #9987

User story #9698: Import node properties from external data sources

Cannot use " in the result of a Datasource

Added by Nicolas CHARLES 11 months ago. Updated 11 months ago.

Status:
Rejected
Priority:
N/A
Category:
Web - Compliance & node report
Target version:
Target version (plugin):
Severity:
User visibility:
Effort required:
Pull Request:
Priority:

Description

I defined a datasource to return a quoted ip adress

Name    Value
test_key    "86.246.132.30" 

when I try to use this property in "Enforce a file content", for content of the file, I get the following error:

⇨ Cannot build target configuration node
⇨ Error with parameters expansion for node 'server.rudder.local' (root): When processing directive 'Enforce a file content': On variable 'GENERIC_FILE_CONTENT_PAYLOAD': Error when parsing value "${node.properties["test_key"]}", error message is: string matching regex `[\-_a-zA-Z0-9]+' expected but `"' found 

Quote are valid in this field (i can put " in it, and it works as expected)
So there is something in the interpolation preventing me from using " in properties

History

#1 Updated by Nicolas CHARLES 11 months ago

  • Status changed from New to Rejected

Ha, the issue is in the name of the key,
it should be ${node.properties[test_key]} and not ${node.properties["test_key"]}

Also available in: Atom PDF