Project

General

Profile

User story #9967

User story #9737: Upgrade CFEngine in Rudder agent to 3.10

Add allowlegacyconnects for compatibility

Added by Alexis MOUSSET 11 months ago. Updated 11 months ago.

Status:
Released
Priority:
N/A
Category:
Initial promises & sys tech
Target version:
Target version (plugin):
Suggestion strength:
User visibility:
Effort required:

Description

Since CFEngine 3.9, legacy protocol is not allowed by default. https://tracker.mender.io/browse/CFE-2339

We need to add an allowlegacyconnects containing the allowed network.


Related issues

Duplicated by Rudder - Architecture #6360: Update allowlegacyconnects to disallow old agents Rejected

Associated revisions

Revision 5569e80e
Added by Alexis MOUSSET 11 months ago

Fixes #9967: Add allowlegacyconnects for compatibility

History

#1 Updated by Alexis MOUSSET 11 months ago

  • Status changed from New to In progress

#2 Updated by Alexis MOUSSET 11 months ago

  • Status changed from In progress to Pending technical review
  • Assignee changed from Alexis MOUSSET to Benoît PECCATTE
  • Pull Request set to https://github.com/Normation/rudder-techniques/pull/1105

#3 Updated by Alexis MOUSSET 11 months ago

  • Status changed from Pending technical review to Pending release
  • % Done changed from 0 to 100

#4 Updated by Vincent MEMBRÉ 11 months ago

  • Parent task set to #9737

#5 Updated by Vincent MEMBRÉ 11 months ago

  • Status changed from Pending release to Released

This bug has been fixed in Rudder 4.1.0 which was released today.

#6 Updated by Benoît PECCATTE 10 months ago

  • Duplicated by Architecture #6360: Update allowlegacyconnects to disallow old agents added

Also available in: Atom PDF