Project

General

Profile

Bug #9639

When running rudder-init on a fresh server, we get an error that "/var/rudder/ncf/local/ does not exist"

Added by Nicolas CHARLES over 1 year ago. Updated over 1 year ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
Packaging
Target version:
Target version (plugin):
Severity:
User visibility:
Effort required:
Pull Request:
Priority:

Description

rudder-init runs following command:

# The previous run will create /var/rudder/configuration-repository/ncf/ncf.conf but it still needs copying to /var/rudder/ncf/local/ncf.conf
if [ -f /var/rudder/configuration-repository/ncf/ncf.conf ]; then
  cp -f /var/rudder/configuration-repository/ncf/ncf.conf /var/rudder/ncf/local/
fi

but we don't check that this folder exists (on fresh install, on SLES, it seems it does not exists yet)


Related issues

Related to Rudder - Bug #7794: rudder-upgrade edits the wrong ncf.conf file causing transitory invalid promises during upgradesReleased2016-01-19
Is duplicate of Rudder - Bug #10028: Transient update error on ncf/localReleased

History

#1 Updated by Nicolas CHARLES over 1 year ago

  • Target version set to 3.1.17

#2 Updated by Nicolas CHARLES over 1 year ago

  • Related to Bug #7794: rudder-upgrade edits the wrong ncf.conf file causing transitory invalid promises during upgrades added

#3 Updated by Vincent MEMBRÉ over 1 year ago

  • Target version changed from 3.1.17 to 3.1.18

#4 Updated by Vincent MEMBRÉ over 1 year ago

  • Target version changed from 3.1.18 to 3.1.19

#5 Updated by Benoît PECCATTE over 1 year ago

  • Is duplicate of Bug #10028: Transient update error on ncf/local added

#6 Updated by Benoît PECCATTE over 1 year ago

  • Status changed from New to Rejected

Same as #10028

Also available in: Atom PDF