Project

General

Profile

Bug #9547

package_install should use another package body when using a specific package version

Added by Alexis MOUSSET about 1 year ago. Updated about 1 month ago.

Status:
Released
Priority:
N/A
Category:
Policies
Target version:
Severity:
User visibility:
Effort required:

Description

We need to provide a body for operations that takes into account the package version.

That would allow making upgrades to a version that is not the latest


Related issues

Related to ncf - Bug #8167: package_install_version_cmp_update should handle all needed package operations Rejected 2016-04-11
Related to ncf - Bug #10110: Unknown option --oldversion introduced in 9547 Released
Related to Rudder - Bug #9283: The rpmPackageInstallation technique tries to install package-* instead of package when no version is specified Released
Related to ncf - Bug #10919: Use a specific package body when no version is specified for yum/rpm Released
Duplicated by ncf - Bug #10462: package verify version (sometimes?) does not check version of packages Rejected

Associated revisions

Revision d2f0c747
Added by Alexis MOUSSET about 1 year ago

Fixes #9547: package_install should use another package body when using a specific package version

History

#1 Updated by Alexis MOUSSET about 1 year ago

  • Status changed from New to In progress
  • Assignee set to Alexis MOUSSET

#2 Updated by Alexis MOUSSET about 1 year ago

  • Status changed from In progress to Pending technical review
  • Assignee changed from Alexis MOUSSET to Nicolas CHARLES
  • Pull Request set to https://github.com/Normation/ncf/pull/497

#3 Updated by Alexis MOUSSET about 1 year ago

  • Related to Bug #8167: package_install_version_cmp_update should handle all needed package operations added

#4 Updated by Alexis MOUSSET about 1 year ago

  • Status changed from Pending technical review to Pending release
  • % Done changed from 0 to 100

#5 Updated by Alexis MOUSSET 10 months ago

  • Related to Bug #10110: Unknown option --oldversion introduced in 9547 added

#6 Updated by Alexis MOUSSET 6 months ago

  • Related to Bug #9283: The rpmPackageInstallation technique tries to install package-* instead of package when no version is specified added

#7 Updated by Alexis MOUSSET 6 months ago

  • Related to Bug #10919: Use a specific package body when no version is specified for yum/rpm added

#8 Updated by Alexis MOUSSET 6 months ago

  • Duplicated by Bug #10462: package verify version (sometimes?) does not check version of packages added

#9 Updated by Vincent MEMBRÉ about 1 month ago

  • Status changed from Pending release to Released
  • Priority set to 0

Also available in: Atom PDF