Project

General

Profile

Bug #7855

When using a ${rudder.node.hostname} value in a component, the compliance level is always Unexpected

Added by Nicolas CHARLES over 2 years ago. Updated over 1 year ago.

Status:
Rejected
Priority:
1
Category:
Web - Compliance & node report
Target version:
Target version (plugin):
Severity:
Major - prevents use of part of Rudder | no simple workaround
User visibility:
Getting started - demo | first install | level 1 Techniques
Effort required:
Pull Request:
Priority:
45

Description

I used ${rudder.node.hostname} in a directive, for a component, and I always got unexepected status, even if the report has the right value (name of the node), and there is only one
I supposed it is linked to #7758

Switching to ${sys.fqhost} (which returns the same value) solved the issue


Related issues

Related to Rudder - Bug #7758: When several directives value have a CFEngine var, we get "unexpected" due to bad regex matchingReleased2016-01-13

History

#1 Updated by Nicolas CHARLES over 2 years ago

  • Related to Bug #7758: When several directives value have a CFEngine var, we get "unexpected" due to bad regex matching added

#2 Updated by Nicolas CHARLES over 2 years ago

Ok, could not reproduce :(

#3 Updated by Nicolas CHARLES over 2 years ago

but the expected report and the ruddersysevent table do match correctly, so there is no reason the the unknown

#4 Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 3.0.14 to 3.0.15

#5 Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 3.0.15 to 3.0.16

#6 Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 3.0.16 to 3.0.17

#7 Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 3.0.17 to 2.11.23

#8 Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 2.11.23 to 302

#9 Updated by Alexis MOUSSET over 2 years ago

  • Target version changed from 302 to 3.1.12

#10 Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 3.1.12 to 3.1.13

#11 Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 3.1.13 to 3.1.14

#12 Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 3.1.14 to 3.1.15

#13 Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 3.1.15 to 3.1.16

#14 Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 3.1.16 to 3.1.17

#15 Updated by Vincent MEMBRÉ almost 2 years ago

  • Target version changed from 3.1.17 to 3.1.18

#16 Updated by Vincent MEMBRÉ over 1 year ago

  • Target version changed from 3.1.18 to 3.1.19

#17 Updated by Jonathan CLARKE over 1 year ago

  • Severity set to Major - prevents use of part of Rudder | no simple workaround
  • User visibility set to Getting started - demo | first install | level 1 Techniques

#18 Updated by Benoît PECCATTE over 1 year ago

  • Priority set to 45

#19 Updated by Nicolas CHARLES over 1 year ago

  • Status changed from New to Rejected

Cannot reproduce, closing

Also available in: Atom PDF