Project

General

Profile

Bug #6723

When we add a node, we have some rules where we loose all compliance

Added by Nicolas CHARLES over 3 years ago. Updated over 1 year ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
Web - Compliance & node report
Target version:
Target version (plugin):
Severity:
Major - prevents use of part of Rudder | no simple workaround
User visibility:
Getting started - demo | first install | level 1 Techniques
Effort required:
Pull Request:
Priority:
45

Description

After #6519, we have most of the rule that don't loose all compliance when accepting a node, but some of them still loose all compliance. Doesn't seem to be related to applied to policy server or relay or something, it seem quite random


Related issues

Related to Rudder - Bug #6519: When we add a node in a rule, we lose all compliance info on this rule applied on it, and we change promises of all the nodes of the ruleReleased2015-05-25

History

#1 Updated by Nicolas CHARLES over 3 years ago

  • Related to User story #2336: rudder-agent : conflict files with rudder-agent-2.3.6-1.el6.i386.rpm and rudder-cfengine-community-1299256513:2.3.6-1.el6.i386 added

#2 Updated by Nicolas CHARLES over 3 years ago

  • Related to deleted (User story #2336: rudder-agent : conflict files with rudder-agent-2.3.6-1.el6.i386.rpm and rudder-cfengine-community-1299256513:2.3.6-1.el6.i386)

#3 Updated by Nicolas CHARLES over 3 years ago

  • Related to Bug #6519: When we add a node in a rule, we lose all compliance info on this rule applied on it, and we change promises of all the nodes of the rule added

#4 Updated by Nicolas CHARLES over 3 years ago

  • Subject changed from When we add a node, we have some rule where we looe all compliance to When we add a node, we have some rules where we loose all compliance

#5 Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 2.11.12 to 2.11.13

#6 Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 2.11.13 to 2.11.14

#7 Updated by Nicolas CHARLES about 3 years ago

this seems to be quite random
I could reproduce it again today
Out of 3 rules, only one had its serial incremented, and it was a rules very simple (only MOTD)

#8 Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 2.11.14 to 2.11.15

#9 Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 2.11.15 to 2.11.16

#10 Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 2.11.16 to 2.11.17

#11 Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 2.11.17 to 2.11.18

#12 Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 2.11.18 to 2.11.19

#13 Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 2.11.19 to 2.11.20

#14 Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 2.11.20 to 2.11.21

#15 Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 2.11.21 to 2.11.22

#16 Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 2.11.22 to 2.11.23

#17 Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 2.11.23 to 2.11.24

#18 Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 2.11.24 to 308

#19 Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 308 to 3.1.14

#20 Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 3.1.14 to 3.1.15

#21 Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 3.1.15 to 3.1.16

#22 Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 3.1.16 to 3.1.17

#23 Updated by Vincent MEMBRÉ almost 2 years ago

  • Target version changed from 3.1.17 to 3.1.18

#24 Updated by Vincent MEMBRÉ over 1 year ago

  • Target version changed from 3.1.18 to 3.1.19

#25 Updated by Jonathan CLARKE over 1 year ago

  • Severity set to Major - prevents use of part of Rudder | no simple workaround
  • User visibility set to Getting started - demo | first install | level 1 Techniques
  • Priority set to 45

#26 Updated by Nicolas CHARLES over 1 year ago

  • Status changed from New to Rejected

This doesn't appear anymore: we fixed the dynamic group computation, so that all rules are correctly computed once
And in 4.x, we have improved the data model

Also available in: Atom PDF