Project

General

Profile

Bug #6319

When all versions of a technique are deprecated, the last deprecation warning should be displayed

Added by Benoît PECCATTE over 3 years ago. Updated over 1 year ago.

Status:
Rejected
Priority:
2
Category:
Web - Config management
Target version:
Target version (plugin):
Severity:
User visibility:
Effort required:
Pull Request:
Priority:

Description

In rudder 3.0, the technique "Zypper package manager configuration" has no version that is not deprecated since it has been fully replaced by another technique.

In the directive menu, when you click on the technique, nothing is displayed by default.
If there is no version candidate, we should display the warning found in the last available version's "deprecated" tag, so that the user is informed that he should use another technique.


Related issues

Related to Rudder - User story #10229: Find a way to display "deprecated" techniques which still contain directives in the directives treeReleased

History

#1 Updated by François ARMAND over 3 years ago

  • Priority changed from N/A to 5

This seems to be a low priority bug, even if it's a nice enhancement, because:

- the "create from last" works,
- clicking on "see deprecated" works.

#2 Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 3.0.2 to 3.0.3

#3 Updated by François ARMAND over 3 years ago

  • Tracker changed from Bug to User story
  • Subject changed from When all versions of a technique are deprecated, nothing is displayed in rudder to When all versions of a technique are deprecated, the last deprecation warning should be displayed
  • Target version changed from 3.0.3 to 3.1.0~beta1

I'm not even sur that it is a bug and not a feature enhancement.
Requalifying as such.

#4 Updated by Jonathan CLARKE over 3 years ago

  • Tracker changed from User story to Bug
  • Assignee set to Vincent MEMBRÉ
  • Priority changed from 5 to 2
  • Target version changed from 3.1.0~beta1 to 3.0.4
  • Reproduced set to No

I disagree, this is a bug to my mind. This will be confusing for users, and we should never display no versions without explaining why.

It seems to me this would be a quick fix, I'd rather see this happen sooner rather than later. This is particularly important because 3.1 will likely deprecate such Techniques ("Zypper package manager configuration").

#5 Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 3.0.4 to 3.0.5

#6 Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 3.0.5 to 3.0.6

#7 Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 3.0.6 to 3.0.7

#8 Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 3.0.7 to 3.0.8

#9 Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 3.0.8 to 3.0.9

#10 Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 3.0.9 to 3.0.10

#11 Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 3.0.10 to 3.0.11

#12 Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 3.0.11 to 3.0.12

#13 Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 3.0.12 to 3.0.13

#14 Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 3.0.13 to 3.0.14

#15 Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 3.0.14 to 3.0.15

#16 Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 3.0.15 to 3.0.16

#17 Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 3.0.16 to 3.0.17

#18 Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 3.0.17 to 302

#19 Updated by Alexis MOUSSET over 2 years ago

  • Target version changed from 302 to 3.1.12

#20 Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 3.1.12 to 3.1.13

#21 Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 3.1.13 to 3.1.14

#22 Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 3.1.14 to 3.1.15

#23 Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 3.1.15 to 3.1.16

#24 Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 3.1.16 to 3.1.17

#25 Updated by Benoît PECCATTE almost 2 years ago

  • Assignee changed from Vincent MEMBRÉ to Raphael GAUTHIER

#26 Updated by Vincent MEMBRÉ almost 2 years ago

  • Target version changed from 3.1.17 to 3.1.18

#27 Updated by Vincent MEMBRÉ over 1 year ago

  • Target version changed from 3.1.18 to 3.1.19

#28 Updated by Benoît PECCATTE over 1 year ago

  • Status changed from New to Rejected

Superseded by #10229

#29 Updated by Benoît PECCATTE over 1 year ago

  • Related to User story #10229: Find a way to display "deprecated" techniques which still contain directives in the directives tree added

Also available in: Atom PDF