Project

General

Profile

Bug #5829

Deleted Technique from NCF builder are still present in Rudder Technique library

Added by Jean Marie ARIES over 3 years ago. Updated about 1 year ago.

Status:
Rejected
Priority:
1
Assignee:
-
Category:
Web - Technique editor
Target version:
Target version (plugin):
Severity:
User visibility:
Effort required:
Pull Request:
Priority:
0

Description

Hi

When we remove a technique from NCF Builder (Delete button), the technique is still present on the Reference Technique library view (Administration / Technique).
How can we clean old techniques ? (remove and git ?)

Update1 [FAR]: for now, the workaround for deleteing an ncf technique is to:
- 1/ delete the technique from ncf-builder
- 2/ goto rudder page "Administration -> Technique", click on the technique in the tree, scroll to bottom of the page and [delete] the technique.

Update2 [FAR]: given feedback from #5670, the less surprising behavior when deleting a technique from ncf-builder would be to:

- remove the technique from the list of active technique
- disable but don't delete directives based on the technique.

tech-lib.jpg (38.3 KB) tech-lib.jpg Jean Marie ARIES, 2014-12-02 09:42

Related issues

Related to Rudder - Bug #5808: Correctly display technique removed from source libraryReleased2014-11-24
Related to Rudder - User story #5670: Auto add ncf Technique to Rudder techniquesReleased2014-11-24
Is duplicate of Rudder - Bug #5432: Deleted Technique from NCF builder are still present in Rudder Technique libraryNew

History

#1 Updated by Jean Marie ARIES over 3 years ago

I confirm this :

git rm -r technique_directory
git commit

is good

#2 Updated by Jean Marie ARIES over 3 years ago

i still have a strange thing (see the screen capture)

No technique available for that active technique

#3 Updated by François ARMAND over 3 years ago

Hello,
I think you have found a duplicate of #5808.

If so, until the version with the correction are published next week, you can try the proposed workaround. Sorry for the unconvenience.

#4 Updated by François ARMAND over 3 years ago

  • Target version set to 3.1.0~beta1

To be more precise: the duplicate (#5808) is for the comment, not for the whole removal from ncf.

So a technique deleted in ncf-builder should be deleted from the fs & git removed, and with the correction of #5808.

For the deletion of technique, we will take into account the feedbacks from comment in #5670

#5 Updated by François ARMAND over 3 years ago

  • Subject changed from Delete Technique from NCF to Deleted Technique from NCF builder are still present in Rudder Technique library
  • Description updated (diff)

#6 Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 3.1.0~beta1 to 3.1.0~rc1

#7 Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 3.1.0~rc1 to 3.1.0

#8 Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 3.1.0 to 3.1.1

#9 Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 3.1.1 to 3.1.2

#10 Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 3.1.2 to 3.1.3

#11 Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 3.1.3 to 3.1.4

#12 Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 3.1.4 to 3.1.5

#13 Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 3.1.5 to 3.1.6

#14 Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 3.1.6 to 3.1.7

#15 Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 3.1.7 to 3.1.8

#16 Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 3.1.8 to 3.1.9

#17 Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 3.1.9 to 3.1.10

#18 Updated by Vincent MEMBRÉ almost 2 years ago

  • Target version changed from 3.1.10 to 3.1.11

#19 Updated by Vincent MEMBRÉ almost 2 years ago

  • Target version changed from 3.1.11 to 3.1.12

#20 Updated by Vincent MEMBRÉ over 1 year ago

  • Target version changed from 3.1.12 to 3.1.13

#21 Updated by Vincent MEMBRÉ over 1 year ago

  • Target version changed from 3.1.13 to 3.1.14

#22 Updated by Vincent MEMBRÉ over 1 year ago

  • Target version changed from 3.1.14 to 3.1.15

#23 Updated by Vincent MEMBRÉ over 1 year ago

  • Target version changed from 3.1.15 to 3.1.16

#24 Updated by Vincent MEMBRÉ over 1 year ago

  • Target version changed from 3.1.16 to 3.1.17

#25 Updated by Vincent MEMBRÉ over 1 year ago

  • Target version changed from 3.1.17 to 3.1.18

#26 Updated by Vincent MEMBRÉ about 1 year ago

  • Target version changed from 3.1.18 to 3.1.19

#27 Updated by François ARMAND about 1 year ago

  • Status changed from New to Rejected
  • Priority set to 0

This is a duplicate from #5432

#28 Updated by François ARMAND about 1 year ago

  • Is duplicate of Bug #5432: Deleted Technique from NCF builder are still present in Rudder Technique library added

Also available in: Atom PDF