Project

General

Profile

Bug #4614

A deleted group on a Rudder server A is still there on a Rudder server B after a synchronization of /var/rudder/configuration-repository

Added by Nicolas PERRON almost 4 years ago. Updated 10 months ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
System integration
Target version:
Target version (plugin):
Severity:
User visibility:
Effort required:
Pull Request:
Priority:
0

Description

On a Rudder server A, a group is deleted but after a synchronization of the folder /var/rudder/configuration-repository (by git push) on a Rudder server B, the group is still present. The synchronization of the repository is followed by a post-hook which trigger a "restore archive".

Nevertheless, on the /var/rudder/configuration-repository, the XML file associated to the deleted group is present although Rudder should remove it and commit the change. The git log show only commits of archive.
I suppose a bug permitted to erase the group from the LDAP and not into the git.

History

#1 Updated by Benoît PECCATTE over 2 years ago

  • Category set to System integration
  • Target version set to 2.10.14

#2 Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 2.10.14 to 2.10.15

#3 Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 2.10.15 to 2.10.16

#4 Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 2.10.16 to 2.10.17

#5 Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 2.10.17 to 2.10.18

#6 Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 2.10.18 to 2.10.19

#7 Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 2.10.19 to 2.10.20

#8 Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 2.10.20 to 2.11.18

#9 Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 2.11.18 to 2.11.19

#10 Updated by Vincent MEMBRÉ almost 2 years ago

  • Target version changed from 2.11.19 to 2.11.20

#11 Updated by Vincent MEMBRÉ almost 2 years ago

  • Target version changed from 2.11.20 to 2.11.21

#12 Updated by Vincent MEMBRÉ over 1 year ago

  • Target version changed from 2.11.21 to 2.11.22

#13 Updated by Vincent MEMBRÉ over 1 year ago

  • Target version changed from 2.11.22 to 2.11.23

#14 Updated by Vincent MEMBRÉ over 1 year ago

  • Target version changed from 2.11.23 to 2.11.24

#15 Updated by Vincent MEMBRÉ over 1 year ago

  • Target version changed from 2.11.24 to 308

#16 Updated by Vincent MEMBRÉ over 1 year ago

  • Target version changed from 308 to 3.1.14

#17 Updated by Vincent MEMBRÉ over 1 year ago

  • Target version changed from 3.1.14 to 3.1.15

#18 Updated by Vincent MEMBRÉ over 1 year ago

  • Target version changed from 3.1.15 to 3.1.16

#19 Updated by Vincent MEMBRÉ over 1 year ago

  • Target version changed from 3.1.16 to 3.1.17

#20 Updated by Vincent MEMBRÉ about 1 year ago

  • Target version changed from 3.1.17 to 3.1.18

#21 Updated by Vincent MEMBRÉ 11 months ago

  • Target version changed from 3.1.18 to 3.1.19

#22 Updated by François ARMAND 10 months ago

  • Status changed from New to Rejected
  • Priority set to 0

I'm closing that ticket because it is about a non supported synchronization scheme and lacks a lot of thing to be able to analysis it further (basically, if the group is /var/rudder/configuration-repository, it is normal that the archive restaure does not delete it).

Even if the problem is "deleting a group does not correctly delete the corresponding xml file in /var/rudder/configuration-repository", the problem is either not here anymore (works as expected in 3.1.x) or the steps to reproduce it are not present.

Also available in: Atom PDF