Project

General

Profile

Bug #4436

/var/log/syslog is polluted by all rudder logs of nodes

Added by Nicolas CHARLES over 4 years ago. Updated over 1 year ago.

Status:
Rejected
Priority:
1
Category:
System integration
Target version:
Target version (plugin):
Severity:
User visibility:
Effort required:
Pull Request:
Priority:
0

Description

when we use rdder , /var/log/syslog get all lot lot of rudder logs, by all nodes.
we should not store reports of node in /var/log/syslog when they are store in the rudder log, because it makes difficut to backup/store the syslog messages, or to look at what is happening

History

#1 Updated by Dennis Cabooter over 4 years ago

Do you mean only on the server or also on the nodes? I would like to see Rudder logging to /var/log/rudder.log instead of /var/log/{syslog,messages} on nodes as well.

#2 Updated by Nicolas CHARLES over 4 years ago

I meant primarly on server, but if the node is polluted as well, we should fixe this

#3 Updated by Nicolas PERRON over 4 years ago

  • Priority changed from N/A to 1

It would be VERY VERY great to remove all the logs of RUdder into /var/log/{syslog,messages} get from cf-agent and crontab.

These messages are really polluting the useful messages, especially when we have to search for an old information. All the useful messages are hidden by the lines of rudder and cf-serverd.
- fail of cf-promises
- execution of cron
- sometimes Rudder reports
- Reports about tcdb eror
- Error about cf-serverd on reading public key
- warning about ldap indexes (on server-side)

#4 Updated by Nicolas CHARLES over 4 years ago

Nicolas

I'm not sure I understand your last part. What you would like is to have all the compliance log in a specific file, and keep everything else in the syslog file ?

#5 Updated by Nicolas PERRON over 4 years ago

Nicolas CHARLES wrote:

Nicolas

I'm not sure I understand your last part. What you would like is to have all the compliance log in a specific file, and keep everything else in the syslog file ?

No, I was listing what are the messages we don't want to have in syslog. A specific file should be more suitable, even if they are all mixed, but not in the syslog file.

#6 Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 2.6.11 to 2.6.12

#7 Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 2.6.12 to 2.6.13

#8 Updated by Vincent MEMBRÉ about 4 years ago

  • Target version changed from 2.6.13 to 2.6.14

#9 Updated by Jonathan CLARKE about 4 years ago

  • Target version changed from 2.6.14 to 2.6.16

#10 Updated by Jonathan CLARKE about 4 years ago

  • Target version changed from 2.6.16 to 2.6.17

#11 Updated by Nicolas PERRON about 4 years ago

  • Target version changed from 2.6.17 to 2.6.18

#12 Updated by Matthieu CERDA almost 4 years ago

  • Target version changed from 2.6.18 to 2.6.19

#13 Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 2.6.19 to 2.6.20

#14 Updated by François ARMAND over 3 years ago

  • Target version changed from 2.6.20 to 2.10.10

#15 Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 2.10.10 to 2.10.11

#16 Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 2.10.11 to 2.10.12

#17 Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 2.10.12 to 2.10.13

#18 Updated by François ARMAND over 3 years ago

  • Category set to System integration
  • Assignee set to Nicolas CHARLES
  • Reproduced set to No

Nico, is this still the case ?

It doesn't seem so, but I can't confirm it.

#19 Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 2.10.13 to 2.10.14

#20 Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 2.10.14 to 2.10.15

#21 Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 2.10.15 to 2.10.16

#22 Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 2.10.16 to 2.10.17

#23 Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 2.10.17 to 2.10.18

#24 Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 2.10.18 to 2.10.19

#25 Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 2.10.19 to 2.10.20

#26 Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 2.10.20 to 2.11.18

#27 Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 2.11.18 to 2.11.19

#28 Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 2.11.19 to 2.11.20

#29 Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 2.11.20 to 2.11.21

#30 Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 2.11.21 to 2.11.22

#31 Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 2.11.22 to 2.11.23

#32 Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 2.11.23 to 2.11.24

#33 Updated by Vincent MEMBRÉ almost 2 years ago

  • Target version changed from 2.11.24 to 308

#34 Updated by Vincent MEMBRÉ almost 2 years ago

  • Target version changed from 308 to 3.1.14

#35 Updated by Vincent MEMBRÉ almost 2 years ago

  • Target version changed from 3.1.14 to 3.1.15

#36 Updated by Vincent MEMBRÉ almost 2 years ago

  • Target version changed from 3.1.15 to 3.1.16

#37 Updated by Vincent MEMBRÉ almost 2 years ago

  • Target version changed from 3.1.16 to 3.1.17

#38 Updated by Vincent MEMBRÉ over 1 year ago

  • Target version changed from 3.1.17 to 3.1.18

#39 Updated by Vincent MEMBRÉ over 1 year ago

  • Target version changed from 3.1.18 to 3.1.19

#40 Updated by François ARMAND over 1 year ago

  • Status changed from New to Rejected
  • Priority set to 0

This is not the case anymore (at least since 3.1.x )

Also available in: Atom PDF