Project

General

Profile

Bug #4334

Technique "Download From A Shared Folder": copy files to directory destination doesn't work

Added by Nicolas PERRON almost 4 years ago. Updated 9 months ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
Techniques
Target version:
Target version (plugin):
Severity:
User visibility:
Effort required:
Pull Request:
Priority:
0

Description

With Download From A Shared Folder, #3646 lead to have a file with name of a directory instead of placing the file in the destination directory.
What is more unfortunate here is that if we copy a file in a path requiring a directory with the same name than a file it will not work.

Example 1:
- /tmp/foo is a directory
- we want to copy file1 in /tmp/foo with "/tmp/foo/" in destination in the Directive
- result: /tmp/foo will be replaced by the content of file1 (cf #3646)

Example 2:
- /tmp/foo is a file
- file2 is another file
- we want to copy file2 in /tmp/foo/bar/baz
- result: the folder /tmp/foo will not be able to be created since a file with the same name already exist

Now, imagine that you made the first mistake, you will have to delete the wrong file (/tmp/foo) before to apply the second example without error.

I suppose we should propose to enforce or not a file/directory during the copy ?


Related issues

Related to Rudder - Bug #3646: Technique "Dowload a file from shared-folder" is not working properly with a source file and a directory as destination Rejected 2013-06-12
Duplicates Rudder - Bug #10312: "Download files from the shared folder" behaving badly? Released

History

#1 Updated by Nicolas PERRON almost 4 years ago

  • Description updated (diff)

#2 Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 2.4.13 to 2.6.11

Since version 2.4 is not maintained anymore, retargeting to branch 2.6

#3 Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 2.6.11 to 2.6.12

#4 Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 2.6.12 to 2.6.13

#5 Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 2.6.13 to 2.6.14

#6 Updated by Jonathan CLARKE over 3 years ago

  • Target version changed from 2.6.14 to 2.6.16

#7 Updated by Jonathan CLARKE over 3 years ago

  • Target version changed from 2.6.16 to 2.6.17

#8 Updated by Nicolas PERRON over 3 years ago

  • Target version changed from 2.6.17 to 2.6.18

#9 Updated by Matthieu CERDA about 3 years ago

  • Target version changed from 2.6.18 to 2.6.19

#10 Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 2.6.19 to 2.6.20

#11 Updated by François ARMAND almost 3 years ago

  • Target version changed from 2.6.20 to 2.10.10

#12 Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 2.10.10 to 2.10.11

#13 Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 2.10.11 to 2.10.12

#14 Updated by Benoît PECCATTE almost 3 years ago

  • Project changed from Techniques to Rudder
  • Category set to Techniques

#15 Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 2.10.12 to 2.10.13

#16 Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 2.10.13 to 2.10.14

#17 Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 2.10.14 to 2.10.15

#18 Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 2.10.15 to 2.10.16

#19 Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 2.10.16 to 2.10.17

#20 Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 2.10.17 to 2.10.18

#21 Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 2.10.18 to 2.10.19

#22 Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 2.10.19 to 2.10.20

#23 Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 2.10.20 to 2.11.18

#24 Updated by Vincent MEMBRÉ almost 2 years ago

  • Target version changed from 2.11.18 to 2.11.19

#25 Updated by Vincent MEMBRÉ almost 2 years ago

  • Target version changed from 2.11.19 to 2.11.20

#26 Updated by Vincent MEMBRÉ over 1 year ago

  • Target version changed from 2.11.20 to 2.11.21

#27 Updated by Vincent MEMBRÉ over 1 year ago

  • Target version changed from 2.11.21 to 2.11.22

#28 Updated by Vincent MEMBRÉ over 1 year ago

  • Target version changed from 2.11.22 to 2.11.23

#29 Updated by Vincent MEMBRÉ over 1 year ago

  • Target version changed from 2.11.23 to 2.11.24

#30 Updated by Vincent MEMBRÉ over 1 year ago

  • Target version changed from 2.11.24 to 308

#31 Updated by Vincent MEMBRÉ about 1 year ago

  • Target version changed from 308 to 3.1.14

#32 Updated by Vincent MEMBRÉ about 1 year ago

  • Target version changed from 3.1.14 to 3.1.15

#33 Updated by Vincent MEMBRÉ about 1 year ago

  • Target version changed from 3.1.15 to 3.1.16

#34 Updated by Vincent MEMBRÉ about 1 year ago

  • Target version changed from 3.1.16 to 3.1.17

#35 Updated by Vincent MEMBRÉ about 1 year ago

  • Target version changed from 3.1.17 to 3.1.18

#36 Updated by Vincent MEMBRÉ 10 months ago

  • Target version changed from 3.1.18 to 3.1.19

#37 Updated by Benoît PECCATTE 9 months ago

  • Subject changed from Technique "Download From A Shared Folder": Copy a file with same name than a directory will replace it by the file but copying a file with a path requiring a directory with the same name than a file will not work to Technique "Download From A Shared Folder": copy files to directory destination doesn't work

#38 Updated by François ARMAND 9 months ago

  • Status changed from New to Rejected
  • Priority set to 0

It is a duplicate of #10312, so I'm closing it.

#39 Updated by François ARMAND 9 months ago

  • Duplicates Bug #10312: "Download files from the shared folder" behaving badly? added

Also available in: Atom PDF