Project

General

Profile

User story #3421

Nested groups

Added by Dennis Cabooter over 5 years ago. Updated over 1 year ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
Web - Nodes & inventories
Target version (plugin):
Suggestion strength:
User visibility:
Effort required:
Pull Request:

Description

It would be nice to have nested groups.

E.g.

- Ubuntu server
  - Ubuntu 10 servers
  - Ubuntu 12 servers

Related issues

Is duplicate of Rudder - User story #2774: Have the possibility to compose groups / nested groups / sub groupsRejected

History

#1 Updated by Vincent MEMBRÉ over 5 years ago

  • Category set to Web - Nodes & inventories
  • Status changed from New to Discussion
  • Target version set to Ideas (not version specific)

So you need a way to create a super group which reference other groups?

Maybe we can handle that by making the group categories as rule target.

The category would targets all nodes contained in its childs.

That would fit well in the webapp, and should be easy to understand.

What do you think about that ?

#2 Updated by Dennis Cabooter about 5 years ago

I'm not sure if I understand what you mean. I will provide a user case. Let's take the groups I mentioned above: Ubuntu Servers, Ubuntu 10 Servers, Ubuntu 12 Servers.

We use different configurations on Ubuntu 10 Servers and Ubuntu 12 Servers, like software repositories. However, most configurations are suitable for both Ubuntu 10 and Ubuntu 12 Servers.

At the moment I can do two things to accomplish this. Or I create three separate groups, Ubuntu Servers, Ubuntu 10 Servers, Ubuntu 12 Servers, based on regexp. Or I just create two separate groups, Ubuntu 10 Servers, Ubuntu 12 Servers, and bind those two groups to one directive.

It would be nice if I was able to create two groups, Ubuntu 10 Servers, Ubuntu 12 Servers, based on regexp. And then make an Ubuntu Servers group which contains both groups.

#3 Updated by Michael Gliwinski almost 5 years ago

Vincent MEMBRÉ wrote:

So you need a way to create a super group which reference other groups?

Maybe we can handle that by making the group categories as rule target.

The category would targets all nodes contained in its childs.

That would fit well in the webapp, and should be easy to understand.

What do you think about that ?

I'll pitch in here and say I think this would work, yes. This also has the additional benefit that categories and groups are already represented hierarchically which is a useful visualization for groups/subgroups.

Another way would be to add query criteria like "is member of".

#4 Updated by Dennis Cabooter over 4 years ago

What is the status of this ticket? Can someone look at it?

#5 Updated by Olivier Mauras over 4 years ago

I agree with the categories being targets in rules. That would make a lot of sense, and would make things easier.

#6 Updated by François ARMAND over 4 years ago

Something related to that topic, even if not what is wanted here: #4505 "Allow exclusion and composition of groups to gain more flexibility in Nodes targetted by a Rule"

#7 Updated by Dennis Cabooter almost 3 years ago

Would be still nice to have this. CFEngine can do it actually.

#8 Updated by Maxime Longuet almost 3 years ago

Yes Very nice. I'm think add in the Filter of dynamic Group choice : Rudder Group Name (== / !=).

With this feature, response of make group intersection on applied rule can have solution.

#9 Updated by Benoît PECCATTE over 1 year ago

  • Is duplicate of User story #2774: Have the possibility to compose groups / nested groups / sub groups added

#10 Updated by Benoît PECCATTE over 1 year ago

  • Status changed from Discussion to Rejected

Duplicates #2774

Also available in: Atom PDF