Project

General

Profile

Bug #2285

No version of rsyslog is specified in rudder-inventory-ldap dependency for debian, although its version is only 3 on lenny

Added by Nicolas PERRON over 5 years ago. Updated about 2 years ago.

Status:
Rejected
Priority:
2
Assignee:
Nicolas PERRON
Category:
Packaging
Target version:
Target version (plugin):
Severity:
User visibility:
Effort required:
Pull Request:
Found in version (s):
How to reproduce:
Reproduced:
No
Priority:

Description

Don't we need at least rsyslog 4 or later ?

History

#1 Updated by Nicolas PERRON about 5 years ago

  • Tracker changed from Bug to Question
  • Subject changed from No version is specified in rudder-inventory-ldap dependency for debian, although its version is only 3 on lenny to No version of rsyslog is specified in rudder-inventory-ldap dependency for debian, although its version is only 3 on lenny
  • Description updated (diff)

#2 Updated by Jonathan CLARKE about 5 years ago

Nicolas PERRON wrote:

Don't we need at least rsyslog 4 or later ?

No, not for rudder-inventory-ldap. The only reason that rudder-inventory-ldap needs syslog is to write it's own logs.

You're getting confused with the specific rsyslog configuration that rudder-reports uses to parse incoming logs from managed nodes. This is unrelated here. See #2284.

#3 Updated by Nicolas PERRON about 5 years ago

  • Status changed from New to Discussion

Jonathan CLARKE wrote:

Nicolas PERRON wrote:

Don't we need at least rsyslog 4 or later ?

No, not for rudder-inventory-ldap. The only reason that rudder-inventory-ldap needs syslog is to write it's own logs.

You're getting confused with the specific rsyslog configuration that rudder-reports uses to parse incoming logs from managed nodes. This is unrelated here. See #2284.

Ok, so having only "rsyslog" in dependencies is correct. Shouldn't we use "system-log-daemon" in order to be more generic ?

#4 Updated by Jonathan CLARKE about 5 years ago

  • Tracker changed from Question to Bug
  • Status changed from Discussion to Rejected

Nicolas PERRON wrote:

Jonathan CLARKE wrote:

Nicolas PERRON wrote:

Don't we need at least rsyslog 4 or later ?

No, not for rudder-inventory-ldap. The only reason that rudder-inventory-ldap needs syslog is to write it's own logs.

You're getting confused with the specific rsyslog configuration that rudder-reports uses to parse incoming logs from managed nodes. This is unrelated here. See #2284.

Ok, so having only "rsyslog" in dependencies is correct. Shouldn't we use "system-log-daemon" in order to be more generic ?

That should be discussed in #2284 (I already started and am waiting for your feedback).

I'm closing this bug as it is invalid.

#5 Updated by Nicolas PERRON over 4 years ago

  • Project changed from Rudder to packages
  • Category deleted (11)

#6 Updated by BenoƮt PECCATTE about 2 years ago

  • Project changed from packages to Rudder
  • Category set to Packaging

Also available in: Atom PDF