Project

General

Profile

Bug #11628

Error at installation of Rudder 4.1 on centos 6

Added by Nicolas CHARLES about 2 months ago. Updated about 1 month ago.

Status:
Released
Priority:
N/A
Category:
Packaging
Target version:
Target version (plugin):
Severity:
User visibility:
Effort required:
Priority:
0

Description

When installing current nightly on centos 4.1, i have the following error

==> centos41_server:
==> centos41_server: *****************************************************************************************
==> centos41_server: INFO: Now run on your root server:                                                            
==> centos41_server: INFO:   '/opt/rudder/bin/rudder-node-to-relay eb26dcdf-6287-4d73-9694-5ca51e513190
==> centos41_server: INFO: Please look at the documentation for details (Section 'Relay servers')          
==> centos41_server: *******************************************************************i*********************
 Installing : tzdata-java-2017b-1.el6.noarch                             34/48
==> centos41_server:  
 Installing : freetype-2.3.11-17.el6.x86_64                              35/48
==> centos41_server:  
 Installing : 1:java-1.8.0-openjdk-headless-1.8.0.144-0.b01.el6_9.x86_   36/48
==> centos41_server:  
 Installing : 1398866025:rudder-jetty-4.1.8.rc1.git201710190307-1.EL.6   37/48
==> centos41_server:  
==> centos41_server: Stopping Jetty: OK
==> centos41_server: Traceback (most recent call last):
==> centos41_server:   File "/opt/rudder/bin/rudder-pkg", line 41, in <module>
==> centos41_server:     import argparse
==> centos41_server: ImportError: No module named argparse
==> centos41_server: error: %pre(rudder-webapp-1398866025:4.1.8.rc1.git201710190307-1.EL.6.noarch) scriptlet failed, exit status 1
==> centos41_server: Error in PREIN scriptlet in rpm package 1398866025:rudder-webapp-4.1.8.rc1.git201710190307-1.EL.6.noarch
==> centos41_server: error:   install: %pre scriptlet failed (2), skipping rudder-webapp-1398866025:4.1.8.rc1.git201710190307-1.EL.6
 Installing : 1398866025:rudder-inventory-endpoint-4.1.8.rc1.git201710   39/48
==> centos41_server:  

webapp is not functionnal afterward

Associated revisions

Revision 83c05458
Added by Alexis MOUSSET about 2 months ago

Fixes #11628: Error at installation of Rudder 4.1 on centos 6

History

#1 Updated by Nicolas CHARLES about 2 months ago

  • Subject changed from Error at installation of Rudder 4.1 on centos to Error at installation of Rudder 4.1 on centos 6

#2 Updated by Nicolas CHARLES about 2 months ago

  • Assignee set to Alexis MOUSSET

installing python-argparse.noarch fixes the issue

#3 Updated by Alexis MOUSSET about 2 months ago

  • Status changed from New to In progress

#4 Updated by Alexis MOUSSET about 2 months ago

  • Status changed from In progress to Pending technical review
  • Assignee changed from Alexis MOUSSET to Benoît PECCATTE
  • Pull Request set to https://github.com/Normation/rudder-packages/pull/1396

#5 Updated by Alexis MOUSSET about 2 months ago

argparse is not part of 2.6 stdlib, we need to make it a dependency.

#6 Updated by Alexis MOUSSET about 2 months ago

  • Status changed from Pending technical review to Pending release

#7 Updated by Vincent MEMBRÉ about 1 month ago

  • Status changed from Pending release to Released

This bug has been fixed in Rudder 4.1.8 and 4.2.1 which were released today.

Also available in: Atom PDF