Project

General

Profile

Bug #11123

If a Rule is enabled but applies no Directive, it is displayed as Disabled

Added by Raphael GAUTHIER 2 months ago. Updated about 1 month ago.

Status:
Released
Priority:
N/A
Category:
Web - UI & UX
Target version:
Target version (plugin):
Severity:
Minor - inconvenience | misleading | easy workaround
User visibility:
Getting started - demo | first install | level 1 Techniques
Effort required:
Priority:
50

Description

This is a bug. Instead, We should display an icon, or something like this, if a Rule applies no Directive (or/and) to no Group.


Related issues

Related to Rudder - Bug #11205: Disabled Rules status is invisible Released

Associated revisions

Revision 9d606096
Added by Raphaël Gauthier about 1 month ago

Fixes #11123: If a Rule is enabled but applies no Directive, it is displayed as Disabled

History

#1 Updated by Raphael GAUTHIER 2 months ago

  • Subject changed from If a Rule is enabled but applies any Directive, it is displayed as Disabled to If a Rule is enabled but applies no Directive, it is displayed as Disabled

#2 Updated by Benoît PECCATTE about 2 months ago

  • User visibility changed from Operational - other Techniques | Technique editor | Rudder settings to Getting started - demo | first install | level 1 Techniques
  • Priority changed from 32 to 50

#3 Updated by François ARMAND about 2 months ago

In the code, we have two notion for rules: "enable / disabled" and "applied / not applied". It seems with the code that the rule can be enable and not applied, so it is "just" a displaying problem.

#4 Updated by Raphael GAUTHIER about 2 months ago

  • Status changed from New to In progress
  • Assignee set to Raphael GAUTHIER

#5 Updated by Raphael GAUTHIER about 2 months ago

  • Related to Bug #11205: Disabled Rules status is invisible added

#6 Updated by Raphael GAUTHIER about 1 month ago

  • Status changed from In progress to Pending technical review
  • Assignee changed from Raphael GAUTHIER to Vincent MEMBRÉ
  • Pull Request set to https://github.com/Normation/rudder/pull/1718

#7 Updated by Anonymous about 1 month ago

  • Status changed from Pending technical review to Pending release

#8 Updated by Vincent MEMBRÉ about 1 month ago

  • Status changed from Pending release to Released

This bug has been fixed in Rudder 4.1.6 and 4.2.0~beta3 which were released today.

Also available in: Atom PDF