Project

General

Profile

Bug #11051

rudder-relay-server install broken due to apache not restarting

Added by François ARMAND 6 months ago. Updated 5 months ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
System integration
Target version:
Target version (plugin):
Severity:
Major - prevents use of part of Rudder | no simple workaround
User visibility:
Getting started - demo | first install | level 1 Techniques
Effort required:
Pull Request:
Priority:
70

Description

On rudder 4.2.0~beta1, the installation of root server fails with:

Setting up rudder-server-relay (4.2.0~prototype~git201706230323-xenial0) ...
INFO: Restarting Apache HTTPd...dpkg: error processing package rudder-server-relay (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of rudder-webapp:
 rudder-webapp depends on rudder-server-relay (= 4.2.0~prototype~git201706230323-xenial0); however:
  Package rudder-server-relay is not configured yet.

dpkg: error processing package rudder-webapp (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of rudder-server-root:
 rudder-server-root depends on rudder-webapp (= 4.2.0~prototype~git201706230323-xenial0); however:
  Package rudder-webapp is not configured yet.

dpkg: error processing package rudder-server-root (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                          No apport report written because the error message indi
cates its a followup error from a previous failure.
                                   Errors were encountered while processing:
 rudder-server-relay
 rudder-webapp
 rudder-server-root
E: Sub-process /usr/bin/dpkg returned an error code (1)

The problem is:

apache2: Syntax error on line 219 of /etc/apache2/apache2.conf: Syntax error on line 49 of /etc/apache2/sites-enabled/rudder.conf: Syntax error on line 33 of /opt/rudder/etc/rudder-apache-relay-ssl.conf: Could not open configuration file /opt/rudder/etc/rudder-share-acl-24.conf: No such file or directory

Related issues

Related to Rudder - Bug #10989: Missing configuration file for Apache2 when installing 4.2 Released

History

#1 Updated by François ARMAND 6 months ago

  • Severity set to Major - prevents use of part of Rudder | no simple workaround
  • User visibility set to Getting started - demo | first install | level 1 Techniques
  • Priority changed from 0 to 70

#2 Updated by François ARMAND 6 months ago

  • Related to Bug #10989: Missing configuration file for Apache2 when installing 4.2 added

#3 Updated by François ARMAND 5 months ago

This may be due to a packaging problem, where the bad sources were used. It need to be tested with last sources.

#4 Updated by Nicolas CHARLES 5 months ago

  • Status changed from New to Rejected

it now works, it was indeed a packaging issue

Also available in: Atom PDF