Project

General

Profile

User story #10724

adding a Hook after node validation

Added by pierrick prost 7 months ago. Updated about 1 month ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
System integration
Target version:
Target version (plugin):
Suggestion strength:
User visibility:
Effort required:
Pull Request:

Description

Hi everyone,

it will be usefull to have an hook after node validation on rudder. I want to automaticcaly monitor it on my monitoring tool (centreon for me) Let me explain my use case :

  • i create anew server instance
  • i add the rudder client to his
  • i validate the node on rudder
  • Rudder's post validation hook call centreon REST API and ADD rudder node informations to the monitoring tools.

That's all. :-)

Thanks.


Related issues

Related to Rudder - User story #10568: Create a hook for pre and post node deletion event Released
Related to Rudder - User story #8353: Implement notifications for different server-side actions and events (hooks) Released 2016-12-22
Duplicates Rudder - User story #11218: Add node-post-acceptance hook Released

History

#1 Updated by François ARMAND 7 months ago

  • Related to User story #10568: Create a hook for pre and post node deletion event added

#2 Updated by François ARMAND 7 months ago

  • Related to User story #8353: Implement notifications for different server-side actions and events (hooks) added

#3 Updated by François ARMAND 7 months ago

Thanks for proposing that user story. It is a clear need, even more now that we have node deletion hooks.

#4 Updated by Benoît PECCATTE about 1 month ago

  • Category set to System integration
  • Status changed from New to Rejected
  • Target version set to 4.1.9

Rejected as a duplicate of #11218
The hook is called node-post-acceptance

#5 Updated by Benoît PECCATTE about 1 month ago

Also available in: Atom PDF