Project

General

Profile

Bug #10427

On freshly installed centos7, ldap connections fail with "bad auth"

Added by François ARMAND 8 months ago. Updated 8 months ago.

Status:
Rejected
Priority:
N/A
Category:
System integration
Target version:
Target version (plugin):
Severity:
Major - prevents use of part of Rudder | no simple workaround
User visibility:
Getting started - demo | first install | level 1 Techniques
Effort required:
Priority:
54

Description

On a fresh Rudder install on centos7, I get a log of ldap bind error (webapp logs, ...)
LDAP password is correctly set on the relevant files (rudder-web.properties, slapd.conf. rudder-passwords.conf)

At that point, running rudder agent (`rudder agent run`) or restarting rudder webapp is useless.

If I restart slapd (`systemctl restart rudder-slapd`), everything starts to work as expected.

If I change LDAP passwd in rudder-passwords.conf and then run rudder agent, the new password is correctly synchronised and both slapd and jetty restarted.


Subtasks

Bug #10487: slapd is started and not stopped in rudder-ivnentory-ldap RejectedAlexis MOUSSET

Associated revisions

Revision 05bb59a7
Added by Vincent MEMBRÉ 8 months ago

Fixes #10427: On freshly installed centos7, ldap connections fail with "bad auth"

Revision 3dd44c4b
Added by Vincent MEMBRÉ 8 months ago

Revert "Fixes #10427: On freshly installed centos7, ldap connections fail with "bad auth""

This reverts commit 05bb59a78f75104051e371cadf489791cffc9cb2.

History

#1 Updated by Nicolas CHARLES 8 months ago

I couldn't reproduce this issue, will try again
Do you have any log of the install ?

#2 Updated by François ARMAND 8 months ago

  • Subject changed from On centos7, slapd is not correctly restarted after first password change to On freshly installed centos7, ldap connections fail with "bad auth"
  • Severity set to Major - prevents use of part of Rudder | no simple workaround
  • User visibility set to Getting started - demo | first install | level 1 Techniques

#3 Updated by Vincent MEMBRÉ 8 months ago

  • Status changed from New to In progress
  • Assignee set to Vincent MEMBRÉ

#4 Updated by Vincent MEMBRÉ 8 months ago

  • Status changed from In progress to Pending technical review
  • Assignee changed from Vincent MEMBRÉ to Benoît PECCATTE
  • Pull Request set to https://github.com/Normation/rudder-packages/pull/1306

#5 Updated by Vincent MEMBRÉ 8 months ago

  • Status changed from Pending technical review to Pending release

#6 Updated by Vincent MEMBRÉ 8 months ago

We need to revert this, this will be fixed in ncf methods directrly in #10488

#7 Updated by Vincent MEMBRÉ 8 months ago

  • Status changed from Pending release to Rejected

#8 Updated by Benoît PECCATTE 8 months ago

  • Priority set to 54

Also available in: Atom PDF