Project

General

Profile

Bug #10426

Apache not started on a fresh centos7 install (selinux problem)

Added by François ARMAND 8 months ago. Updated 7 months ago.

Status:
Released
Priority:
N/A
Category:
System integration
Target version:
Target version (plugin):
Severity:
Critical - prevents main use of Rudder | no workaround | data loss | security
User visibility:
Getting started - demo | first install | level 1 Techniques
Effort required:
Priority:
78

Description

On fresh centos 7 install, apache server is not started.

It seems that the problem is with systemd, because:

root@server:/home/vagrant# systemctl start httpd
Job for httpd.service failed because the control process exited with error code. See "systemctl status httpd.service" and "journalctl -xe" for details.
root@server:/home/vagrant# systemctl status httpd
● httpd.service - The Apache HTTP Server
   Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Wed 2017-03-15 17:03:56 UTC; 5s ago
     Docs: man:httpd(8)
           man:apachectl(8)
  Process: 4512 ExecStop=/bin/kill -WINCH ${MAINPID} (code=exited, status=1/FAILURE)
  Process: 4510 ExecStart=/usr/sbin/httpd $OPTIONS -DFOREGROUND (code=exited, status=0/SUCCESS)
 Main PID: 4510 (code=exited, status=0/SUCCESS)

Mar 15 17:03:56 server systemd[1]: Starting The Apache HTTP Server...
Mar 15 17:03:56 server httpd[4510]: httpd (pid 28970) already running
Mar 15 17:03:56 server kill[4512]: kill: cannot find process "" 
Mar 15 17:03:56 server systemd[1]: httpd.service: control process exited, code=exited status=1
Mar 15 17:03:56 server systemd[1]: Failed to start The Apache HTTP Server.
Mar 15 17:03:56 server systemd[1]: Unit httpd.service entered failed state.
Mar 15 17:03:56 server systemd[1]: httpd.service failed.
root@server:/home/vagrant#

BUT: just executing:

root@server:/home/vagrant# httpd
root@server:/home/vagrant# root@server:/home/vagrant# ps aux | grep http
apache    1040  0.0  0.6 361856  9220 ?        S    16:58   0:00 httpd
apache    1041  0.0  0.5 361968  9096 ?        S    16:58   0:00 httpd
apache    1042  0.0  0.5 361832  8780 ?        S    16:58   0:00 httpd
...

And then Rudder works


Subtasks

Bug #10479: Remove all calls to semanage in our packagesReleasedBenoît PECCATTE

Bug #10481: Backport parent fix to 3.1ReleasedBenoît PECCATTE

Bug #10491: selinux policy should be applied at the end of postinstall or technique folder will not be managed correctlyReleasedAlexis MOUSSET


Related issues

Related to Rudder - Bug #10372: On Centos 7.3, upgrading from 4.0 to 4.1 fail due to SELinux problem Released

Associated revisions

Revision 08041f00
Added by Vincent MEMBRÉ 8 months ago

Fixes #10426: Apache not started on a fresh centos7 install (selinux problem)

History

#1 Updated by Nicolas CHARLES 8 months ago

i do confirm this issue

#2 Updated by Nicolas CHARLES 8 months ago

(13)Permission denied: AH00091: httpd: could not open error log file /var/log/rudder/apache2/error.log.
AH00015: Unable to open logs

#3 Updated by Nicolas CHARLES 8 months ago

This is a SELinux issue during install

==> centos7_server: Failed to resolve typeattributeset statement at /etc/selinux/targeted/tmp/modules/400/rudder-relay/cil:1
==> centos7_server: semodule:  Failed!
==> centos7_server: INFO: Applying ncf-api-virtualenv selinux policy...Failed to resolve typeattributeset statement at /etc/selinux/targeted/tmp/modules/400/ncf-api-virtualenv/cil:1
==> centos7_server: semodule:  Failed!
==> centos7_server: libsemanage.semanage_read_policydb: Could not open kernel policy /etc/selinux/targeted/active/policy.kern for reading. (No such file or directory).
==> centos7_server: OSError: No such file or directory
==> centos7_server: INFO: Adding ncf-api-venv to the rudder group... Done
==> centos7_server: Failed to resolve typeattributeset statement at /etc/selinux/targeted/tmp/modules/400/rudder-webapp/cil:1
==> centos7_server: semodule:  Failed!
==> centos7_server: INFO: Starting Apache HTTPd...Job for httpd.service failed because the control process exited with error code. See "systemctl status httpd.service" and "journalctl -xe" for details.
==> centos7_server:  Done
==> centos7_server: libsemanage.semanage_read_policydb: Could not open kernel policy /etc/selinux/targeted/active/policy.kern for reading. (No such file or directory).
==> centos7_server: OSError: No such file or directory

#4 Updated by Nicolas CHARLES 8 months ago

  • Related to Bug #10372: On Centos 7.3, upgrading from 4.0 to 4.1 fail due to SELinux problem added

#5 Updated by François ARMAND 8 months ago

  • Subject changed from Apache not started on a fresh centos7 install to Apache not started on a fresh centos7 install (selinux problem)

#6 Updated by Alexis MOUSSET 8 months ago

  • Related to Bug #10118: Selinux Policy may not be correctly applied if selinux packages are updated during install added

#7 Updated by François ARMAND 8 months ago

  • Severity set to Critical - prevents main use of Rudder | no workaround | data loss | security
  • User visibility set to Getting started - demo | first install | level 1 Techniques

#8 Updated by Vincent MEMBRÉ 8 months ago

  • Status changed from New to In progress
  • Assignee set to Vincent MEMBRÉ

#9 Updated by Vincent MEMBRÉ 8 months ago

  • Status changed from In progress to Pending technical review
  • Assignee changed from Vincent MEMBRÉ to Benoît PECCATTE
  • Pull Request set to https://github.com/Normation/rudder-packages/pull/1307

#10 Updated by Vincent MEMBRÉ 8 months ago

  • Status changed from Pending technical review to Pending release

#11 Updated by Nicolas CHARLES 8 months ago

it doesn't seem competly fixed:

==> centos7_server: Dependencies Resolved
==> centos7_server: 
==> centos7_server: ================================================================================
==> centos7_server:  Package               Arch        Version                   Repository    Size
==> centos7_server: ================================================================================
==> centos7_server: Installing:
==> centos7_server:  git                   x86_64      1.8.3.1-6.el7_2.1         base         4.4 M
==> centos7_server:  nano                  x86_64      2.3.1-10.el7              base         440 k
==> centos7_server:  rsync                 x86_64      3.0.9-17.el7              base         360 k
==> centos7_server:  tree                  x86_64      1.6.0-10.el7              base          46 k
==> centos7_server:  vim-enhanced          x86_64      2:7.4.160-1.el7_3.1       updates      1.0 M
==> centos7_server:  zsh                   x86_64      5.0.2-25.el7_3.1          updates      2.4 M
==> centos7_server: Updating:
==> centos7_server:  binutils              x86_64      2.25.1-22.base.el7        base         5.4 M
==> centos7_server:  curl                  x86_64      7.29.0-35.el7.centos      base         265 k
==> centos7_server: Installing for dependencies:
==> centos7_server:  gpm-libs              x86_64      1.20.7-5.el7              base          32 k
==> centos7_server:  libgnome-keyring      x86_64      3.8.0-3.el7               base         109 k
==> centos7_server:  perl-Error            noarch      1:0.17020-2.el7           base          32 k
==> centos7_server:  perl-Git              noarch      1.8.3.1-6.el7_2.1         base          53 k
==> centos7_server:  perl-TermReadKey      x86_64      2.30-20.el7               base          31 k
==> centos7_server:  vim-common            x86_64      2:7.4.160-1.el7_3.1       updates      5.9 M
==> centos7_server:  vim-filesystem        x86_64      2:7.4.160-1.el7_3.1       updates      9.7 k
==> centos7_server: Updating for dependencies:
==> centos7_server:  libcurl               x86_64      7.29.0-35.el7.centos      base         218 k
==> centos7_server: 
==> centos7_server: Transaction Summary
==> centos7_server: ================================================================================
==> centos7_server: Install  6 Packages (+7 Dependent packages)
==> centos7_server: Upgrade  2 Packages (+1 Dependent package)
==> centos7_server: Total download size: 21 M
==> centos7_server: Downloading packages:
==> centos7_server: Delta RPMs disabled because /usr/bin/applydeltarpm not installed.
==> centos7_server: --------------------------------------------------------------------------------
==> centos7_server: Total                                              1.6 MB/s |  21 MB  00:13     
==> centos7_server: Running transaction check
==> centos7_server: Running transaction test
==> centos7_server: Transaction test succeeded
==> centos7_server: Running transaction
==> centos7_server:   Updating   : libcurl-7.29.0-35.el7.centos.x86_64                         1/19
==> centos7_server:  
==> centos7_server:   Installing : 1:perl-Error-0.17020-2.el7.noarch                           2/19
==> centos7_server:  
==> centos7_server:   Installing : gpm-libs-1.20.7-5.el7.x86_64                                3/19
==> centos7_server:  
==> centos7_server:   Installing : rsync-3.0.9-17.el7.x86_64                                   4/19
==> centos7_server:  
==> centos7_server:   Installing : libgnome-keyring-3.8.0-3.el7.x86_64                         5/19
==> centos7_server:  
==> centos7_server:   Installing : perl-TermReadKey-2.30-20.el7.x86_64                         6/19
==> centos7_server:  
==> centos7_server:   Installing : perl-Git-1.8.3.1-6.el7_2.1.noarch                           7/19
==> centos7_server:  
==> centos7_server:   Installing : git-1.8.3.1-6.el7_2.1.x86_64                                8/19
==> centos7_server:  
==> centos7_server:   Installing : 2:vim-filesystem-7.4.160-1.el7_3.1.x86_64                   9/19
==> centos7_server:  
==> centos7_server:   Installing : 2:vim-common-7.4.160-1.el7_3.1.x86_64                      10/19
==> centos7_server:  
==> centos7_server:   Installing : 2:vim-enhanced-7.4.160-1.el7_3.1.x86_64                    11/19
==> centos7_server:  
==> centos7_server:   Updating   : curl-7.29.0-35.el7.centos.x86_64                           12/19
==> centos7_server:  
==> centos7_server:   Installing : nano-2.3.1-10.el7.x86_64                                   13/19
==> centos7_server:  
==> centos7_server:   Installing : zsh-5.0.2-25.el7_3.1.x86_64                                14/19
==> centos7_server:  
==> centos7_server:   Installing : tree-1.6.0-10.el7.x86_64                                   15/19
==> centos7_server:  
==> centos7_server:   Updating   : binutils-2.25.1-22.base.el7.x86_64                         16/19
==> centos7_server:  
==> centos7_server:   Cleanup    : curl-7.29.0-25.el7.centos.x86_64                           17/19
==> centos7_server:  
==> centos7_server:   Cleanup    : libcurl-7.29.0-25.el7.centos.x86_64                        18/19
==> centos7_server:  
==> centos7_server:   Cleanup    : binutils-2.23.52.0.1-55.el7.x86_64                         19/19
==> centos7_server:  
==> centos7_server:   Verifying  : curl-7.29.0-35.el7.centos.x86_64                            1/19
==> centos7_server:  
==> centos7_server:   Verifying  : 1:perl-Error-0.17020-2.el7.noarch                           2/19
==> centos7_server:  
==> centos7_server:   Verifying  : 2:vim-filesystem-7.4.160-1.el7_3.1.x86_64                   3/19
==> centos7_server:  
==> centos7_server:   Verifying  : perl-TermReadKey-2.30-20.el7.x86_64                         4/19
==> centos7_server:  
==> centos7_server:   Verifying  : perl-Git-1.8.3.1-6.el7_2.1.noarch                           5/19
==> centos7_server:  
==> centos7_server:   Verifying  : binutils-2.25.1-22.base.el7.x86_64                          6/19
==> centos7_server:  
==> centos7_server:   Verifying  : 2:vim-common-7.4.160-1.el7_3.1.x86_64                       7/19
==> centos7_server:  
==> centos7_server:   Verifying  : tree-1.6.0-10.el7.x86_64                                    8/19
==> centos7_server:  
==> centos7_server:   Verifying  : zsh-5.0.2-25.el7_3.1.x86_64                                 9/19
==> centos7_server:  
==> centos7_server:   Verifying  : libcurl-7.29.0-35.el7.centos.x86_64                        10/19
==> centos7_server:  
==> centos7_server:   Verifying  : git-1.8.3.1-6.el7_2.1.x86_64                               11/19
==> centos7_server:  
==> centos7_server:   Verifying  : 2:vim-enhanced-7.4.160-1.el7_3.1.x86_64                    12/19
==> centos7_server:  
==> centos7_server:   Verifying  : nano-2.3.1-10.el7.x86_64                                   13/19
==> centos7_server:  
==> centos7_server:   Verifying  : libgnome-keyring-3.8.0-3.el7.x86_64                        14/19
==> centos7_server:  
==> centos7_server:   Verifying  : rsync-3.0.9-17.el7.x86_64                                  15/19
==> centos7_server:  
==> centos7_server:   Verifying  : gpm-libs-1.20.7-5.el7.x86_64                               16/19
==> centos7_server:  
==> centos7_server:   Verifying  : libcurl-7.29.0-25.el7.centos.x86_64                        17/19
==> centos7_server:  
==> centos7_server:   Verifying  : curl-7.29.0-25.el7.centos.x86_64                           18/19
==> centos7_server:  
==> centos7_server:   Verifying  : binutils-2.23.52.0.1-55.el7.x86_64                         19/19
==> centos7_server:  
==> centos7_server: 
==> centos7_server: Installed:
==> centos7_server:   git.x86_64 0:1.8.3.1-6.el7_2.1              nano.x86_64 0:2.3.1-10.el7       
==> centos7_server:   rsync.x86_64 0:3.0.9-17.el7                 tree.x86_64 0:1.6.0-10.el7       
==> centos7_server:   vim-enhanced.x86_64 2:7.4.160-1.el7_3.1     zsh.x86_64 0:5.0.2-25.el7_3.1    
==> centos7_server: 
==> centos7_server: Dependency Installed:
==> centos7_server:   gpm-libs.x86_64 0:1.20.7-5.el7                                                
==> centos7_server:   libgnome-keyring.x86_64 0:3.8.0-3.el7                                         
==> centos7_server:   perl-Error.noarch 1:0.17020-2.el7                                             
==> centos7_server:   perl-Git.noarch 0:1.8.3.1-6.el7_2.1                                           
==> centos7_server:   perl-TermReadKey.x86_64 0:2.30-20.el7                                         
==> centos7_server:   vim-common.x86_64 2:7.4.160-1.el7_3.1                                         
==> centos7_server:   vim-filesystem.x86_64 2:7.4.160-1.el7_3.1                                     
==> centos7_server: 
==> centos7_server: Updated:
==> centos7_server:   binutils.x86_64 0:2.25.1-22.base.el7    curl.x86_64 0:7.29.0-35.el7.centos   
==> centos7_server: 
==> centos7_server: Dependency Updated:
==> centos7_server:   libcurl.x86_64 0:7.29.0-35.el7.centos                                         
==> centos7_server: Complete!
==> centos7_server: Loaded plugins: fastestmirror
==> centos7_server: Loading mirror speeds from cached hostfile
==> centos7_server:  * base: centos.quelquesmots.fr
==> centos7_server:  * epel: mirror.ibcp.fr
==> centos7_server:  * extras: mirror.ibcp.fr
==> centos7_server:  * updates: centos.mirror.fr.planethoster.net
==> centos7_server: No package ldapscripts available.
==> centos7_server: Resolving Dependencies
==> centos7_server: --> Running transaction check
==> centos7_server: ---> Package htop.x86_64 0:2.0.2-1.el7 will be installed
==> centos7_server: --> Finished Dependency Resolution
==> centos7_server: 
==> centos7_server: Dependencies Resolved
==> centos7_server: 
==> centos7_server: ================================================================================
==> centos7_server:  Package         Arch              Version                Repository       Size
==> centos7_server: ================================================================================
==> centos7_server: Installing:
==> centos7_server:  htop            x86_64            2.0.2-1.el7            epel             98 k
==> centos7_server: 
==> centos7_server: Transaction Summary
==> centos7_server: ================================================================================
==> centos7_server: Install  1 Package
==> centos7_server: Total download size: 98 k
==> centos7_server: Installed size: 207 k
==> centos7_server: Downloading packages:
==> centos7_server: Running transaction check
==> centos7_server: Running transaction test
==> centos7_server: Transaction test succeeded
==> centos7_server: Running transaction
==> centos7_server:   Installing : htop-2.0.2-1.el7.x86_64                                      1/1
==> centos7_server:  
==> centos7_server:   Verifying  : htop-2.0.2-1.el7.x86_64                                      1/1
==> centos7_server:  
==> centos7_server: 
==> centos7_server: Installed:
==> centos7_server:   htop.x86_64 0:2.0.2-1.el7                                                     
==> centos7_server: 
==> centos7_server: Complete!
==> centos7_server: find: ‘/tmp/vagrant-cache’: No such file or directory
==> centos7_server: find: ‘/tmp/vagrant-cache’: No such file or directory
==> centos7_server: Loaded plugins: fastestmirror
==> centos7_server: Loading mirror speeds from cached hostfile
==> centos7_server:  * base: centos.quelquesmots.fr
==> centos7_server:  * epel: mirror.ibcp.fr
==> centos7_server:  * extras: mirror.ibcp.fr
==> centos7_server:  * updates: centos.mirror.fr.planethoster.net
==> centos7_server: Resolving Dependencies
==> centos7_server: --> Running transaction check
==> centos7_server: ---> Package rudder-server-root.noarch 1398866025:4.0.4.rc1.git201703220317-1.EL.7 will be installed
==> centos7_server: --> Processing Dependency: rudder-inventory-endpoint = 1398866025:4.0.4.rc1.git201703220317 for package: 1398866025:rudder-server-root-4.0.4.rc1.git201703220317-1.EL.7.noarch
==> centos7_server: --> Processing Dependency: rudder-inventory-ldap = 1398866025:4.0.4.rc1.git201703220317 for package: 1398866025:rudder-server-root-4.0.4.rc1.git201703220317-1.EL.7.noarch
==> centos7_server: --> Processing Dependency: rudder-agent = 1398866025:4.0.4.rc1.git201703220317 for package: 1398866025:rudder-server-root-4.0.4.rc1.git201703220317-1.EL.7.noarch
==> centos7_server: --> Processing Dependency: rudder-webapp = 1398866025:4.0.4.rc1.git201703220317 for package: 1398866025:rudder-server-root-4.0.4.rc1.git201703220317-1.EL.7.noarch
==> centos7_server: --> Processing Dependency: rudder-reports = 1398866025:4.0.4.rc1.git201703220317 for package: 1398866025:rudder-server-root-4.0.4.rc1.git201703220317-1.EL.7.noarch
==> centos7_server: --> Processing Dependency: rudder-jetty = 1398866025:4.0.4.rc1.git201703220317 for package: 1398866025:rudder-server-root-4.0.4.rc1.git201703220317-1.EL.7.noarch
==> centos7_server: --> Running transaction check
==> centos7_server: ---> Package rudder-agent.i686 1398866025:4.0.4.rc1.git201703220447-1.EL.7 will be installed
==> centos7_server: --> Processing Dependency: net-tools for package: 1398866025:rudder-agent-4.0.4.rc1.git201703220447-1.EL.7.i686
==> centos7_server: ---> Package rudder-inventory-endpoint.noarch 1398866025:4.0.4.rc1.git201703220317-1.EL.7 will be installed
==> centos7_server: ---> Package rudder-inventory-ldap.x86_64 1398866025:4.0.4.rc1.git201703220317-1.EL.7 will be installed
==> centos7_server: --> Processing Dependency: libltdl.so.7()(64bit) for package: 1398866025:rudder-inventory-ldap-4.0.4.rc1.git201703220317-1.EL.7.x86_64
==> centos7_server: ---> Package rudder-jetty.noarch 1398866025:4.0.4.rc1.git201703220317-1.EL.7 will be installed
==> centos7_server: --> Processing Dependency: jre >= 1.7 for package: 1398866025:rudder-jetty-4.0.4.rc1.git201703220317-1.EL.7.noarch
==> centos7_server: ---> Package rudder-reports.noarch 1398866025:4.0.4.rc1.git201703220317-1.EL.7 will be installed
==> centos7_server: --> Processing Dependency: rsyslog-pgsql >= 4 for package: 1398866025:rudder-reports-4.0.4.rc1.git201703220317-1.EL.7.noarch
==> centos7_server: --> Processing Dependency: postgresql-server >= 8.4 for package: 1398866025:rudder-reports-4.0.4.rc1.git201703220317-1.EL.7.noarch
==> centos7_server: ---> Package rudder-webapp.noarch 1398866025:4.0.4.rc1.git201703220317-1.EL.7 will be installed
==> centos7_server: --> Processing Dependency: rudder-techniques = 1398866025:4.0.4.rc1.git201703220317 for package: 1398866025:rudder-webapp-4.0.4.rc1.git201703220317-1.EL.7.noarch
==> centos7_server: --> Processing Dependency: postgresql >= 8.4 for package: 1398866025:rudder-webapp-4.0.4.rc1.git201703220317-1.EL.7.noarch
==> centos7_server: --> Processing Dependency: ncf for package: 1398866025:rudder-webapp-4.0.4.rc1.git201703220317-1.EL.7.noarch
==> centos7_server: --> Processing Dependency: openldap-clients for package: 1398866025:rudder-webapp-4.0.4.rc1.git201703220317-1.EL.7.noarch
==> centos7_server: --> Processing Dependency: httpd-tools for package: 1398866025:rudder-webapp-4.0.4.rc1.git201703220317-1.EL.7.noarch
==> centos7_server: --> Processing Dependency: httpd for package: 1398866025:rudder-webapp-4.0.4.rc1.git201703220317-1.EL.7.noarch
==> centos7_server: --> Processing Dependency: ncf-api-virtualenv for package: 1398866025:rudder-webapp-4.0.4.rc1.git201703220317-1.EL.7.noarch
==> centos7_server: --> Processing Dependency: mod_ssl for package: 1398866025:rudder-webapp-4.0.4.rc1.git201703220317-1.EL.7.noarch
==> centos7_server: --> Running transaction check
==> centos7_server: ---> Package httpd.x86_64 0:2.4.6-45.el7.centos will be installed
==> centos7_server: --> Processing Dependency: /etc/mime.types for package: httpd-2.4.6-45.el7.centos.x86_64
==> centos7_server: --> Processing Dependency: libaprutil-1.so.0()(64bit) for package: httpd-2.4.6-45.el7.centos.x86_64
==> centos7_server: --> Processing Dependency: libapr-1.so.0()(64bit) for package: httpd-2.4.6-45.el7.centos.x86_64
==> centos7_server: ---> Package httpd-tools.x86_64 0:2.4.6-45.el7.centos will be installed
==> centos7_server: ---> Package java-1.8.0-openjdk.x86_64 1:1.8.0.121-0.b13.el7_3 will be installed
==> centos7_server: --> Processing Dependency: java-1.8.0-openjdk-headless = 1:1.8.0.121-0.b13.el7_3 for package: 1:java-1.8.0-openjdk-1.8.0.121-0.b13.el7_3.x86_64
==> centos7_server: --> Processing Dependency: xorg-x11-fonts-Type1 for package: 1:java-1.8.0-openjdk-1.8.0.121-0.b13.el7_3.x86_64
==> centos7_server: --> Processing Dependency: libpng15.so.15(PNG15_0)(64bit) for package: 1:java-1.8.0-openjdk-1.8.0.121-0.b13.el7_3.x86_64
==> centos7_server: --> Processing Dependency: libjvm.so(SUNWprivate_1.1)(64bit) for package: 1:java-1.8.0-openjdk-1.8.0.121-0.b13.el7_3.x86_64
==> centos7_server: --> Processing Dependency: libjpeg.so.62(LIBJPEG_6.2)(64bit) for package: 1:java-1.8.0-openjdk-1.8.0.121-0.b13.el7_3.x86_64
==> centos7_server: --> Processing Dependency: libjli.so(SUNWprivate_1.1)(64bit) for package: 1:java-1.8.0-openjdk-1.8.0.121-0.b13.el7_3.x86_64
==> centos7_server: --> Processing Dependency: libjava.so(SUNWprivate_1.1)(64bit) for package: 1:java-1.8.0-openjdk-1.8.0.121-0.b13.el7_3.x86_64
==> centos7_server: --> Processing Dependency: fontconfig(x86-64) for package: 1:java-1.8.0-openjdk-1.8.0.121-0.b13.el7_3.x86_64
==> centos7_server: --> Processing Dependency: libpng15.so.15()(64bit) for package: 1:java-1.8.0-openjdk-1.8.0.121-0.b13.el7_3.x86_64
==> centos7_server: --> Processing Dependency: libjvm.so()(64bit) for package: 1:java-1.8.0-openjdk-1.8.0.121-0.b13.el7_3.x86_64
==> centos7_server: --> Processing Dependency: libjpeg.so.62()(64bit) for package: 1:java-1.8.0-openjdk-1.8.0.121-0.b13.el7_3.x86_64
==> centos7_server: --> Processing Dependency: libjli.so()(64bit) for package: 1:java-1.8.0-openjdk-1.8.0.121-0.b13.el7_3.x86_64
==> centos7_server: --> Processing Dependency: libjava.so()(64bit) for package: 1:java-1.8.0-openjdk-1.8.0.121-0.b13.el7_3.x86_64
==> centos7_server: --> Processing Dependency: libgif.so.4()(64bit) for package: 1:java-1.8.0-openjdk-1.8.0.121-0.b13.el7_3.x86_64
==> centos7_server: --> Processing Dependency: libawt.so()(64bit) for package: 1:java-1.8.0-openjdk-1.8.0.121-0.b13.el7_3.x86_64
==> centos7_server: --> Processing Dependency: libXtst.so.6()(64bit) for package: 1:java-1.8.0-openjdk-1.8.0.121-0.b13.el7_3.x86_64
==> centos7_server: --> Processing Dependency: libXrender.so.1()(64bit) for package: 1:java-1.8.0-openjdk-1.8.0.121-0.b13.el7_3.x86_64
==> centos7_server: --> Processing Dependency: libXi.so.6()(64bit) for package: 1:java-1.8.0-openjdk-1.8.0.121-0.b13.el7_3.x86_64
==> centos7_server: --> Processing Dependency: libXext.so.6()(64bit) for package: 1:java-1.8.0-openjdk-1.8.0.121-0.b13.el7_3.x86_64
==> centos7_server: --> Processing Dependency: libXcomposite.so.1()(64bit) for package: 1:java-1.8.0-openjdk-1.8.0.121-0.b13.el7_3.x86_64
==> centos7_server: --> Processing Dependency: libX11.so.6()(64bit) for package: 1:java-1.8.0-openjdk-1.8.0.121-0.b13.el7_3.x86_64
==> centos7_server: ---> Package libtool-ltdl.x86_64 0:2.4.2-21.el7_2 will be installed
==> centos7_server: ---> Package mod_ssl.x86_64 1:2.4.6-45.el7.centos will be installed
==> centos7_server: ---> Package ncf.noarch 1398866025:1.0.0.201703220427-1.EL.7 will be installed
==> centos7_server: ---> Package ncf-api-virtualenv.noarch 1398866025:4.0.4.rc1.git201703220317-1.EL.7 will be installed
==> centos7_server: --> Processing Dependency: mod_wsgi for package: 1398866025:ncf-api-virtualenv-4.0.4.rc1.git201703220317-1.EL.7.noarch
==> centos7_server: --> Processing Dependency: policycoreutils-python for package: 1398866025:ncf-api-virtualenv-4.0.4.rc1.git201703220317-1.EL.7.noarch
==> centos7_server: ---> Package net-tools.x86_64 0:2.0-0.17.20131004git.el7 will be installed
==> centos7_server: ---> Package openldap-clients.x86_64 0:2.4.40-13.el7 will be installed
==> centos7_server: --> Processing Dependency: openldap(x86-64) = 2.4.40-13.el7 for package: openldap-clients-2.4.40-13.el7.x86_64
==> centos7_server: ---> Package postgresql.x86_64 0:9.2.18-1.el7 will be installed
==> centos7_server: --> Processing Dependency: postgresql-libs(x86-64) = 9.2.18-1.el7 for package: postgresql-9.2.18-1.el7.x86_64
==> centos7_server: --> Processing Dependency: libpq.so.5()(64bit) for package: postgresql-9.2.18-1.el7.x86_64
==> centos7_server: ---> Package postgresql-server.x86_64 0:9.2.18-1.el7 will be installed
==> centos7_server: ---> Package rsyslog-pgsql.x86_64 0:7.4.7-16.el7 will be installed
==> centos7_server: --> Processing Dependency: rsyslog = 7.4.7-16.el7 for package: rsyslog-pgsql-7.4.7-16.el7.x86_64
==> centos7_server: ---> Package rudder-techniques.noarch 1398866025:4.0.4.rc1.git201703220317-1.EL.7 will be installed
==> centos7_server: --> Running transaction check
==> centos7_server: ---> Package apr.x86_64 0:1.4.8-3.el7 will be installed
==> centos7_server: ---> Package apr-util.x86_64 0:1.5.2-6.el7 will be installed
==> centos7_server: ---> Package fontconfig.x86_64 0:2.10.95-10.el7 will be installed
==> centos7_server: --> Processing Dependency: fontpackages-filesystem for package: fontconfig-2.10.95-10.el7.x86_64
==> centos7_server: ---> Package giflib.x86_64 0:4.1.6-9.el7 will be installed
==> centos7_server: --> Processing Dependency: libSM.so.6()(64bit) for package: giflib-4.1.6-9.el7.x86_64
==> centos7_server: --> Processing Dependency: libICE.so.6()(64bit) for package: giflib-4.1.6-9.el7.x86_64
==> centos7_server: ---> Package java-1.8.0-openjdk-headless.x86_64 1:1.8.0.121-0.b13.el7_3 will be installed
==> centos7_server: --> Processing Dependency: tzdata-java >= 2015d for package: 1:java-1.8.0-openjdk-headless-1.8.0.121-0.b13.el7_3.x86_64
==> centos7_server: --> Processing Dependency: nss(x86-64) >= 3.21.3 for package: 1:java-1.8.0-openjdk-headless-1.8.0.121-0.b13.el7_3.x86_64
==> centos7_server: --> Processing Dependency: copy-jdk-configs >= 1.1-3 for package: 1:java-1.8.0-openjdk-headless-1.8.0.121-0.b13.el7_3.x86_64
==> centos7_server: --> Processing Dependency: chkconfig >= 1.7 for package: 1:java-1.8.0-openjdk-headless-1.8.0.121-0.b13.el7_3.x86_64
==> centos7_server: --> Processing Dependency: chkconfig >= 1.7 for package: 1:java-1.8.0-openjdk-headless-1.8.0.121-0.b13.el7_3.x86_64
==> centos7_server: --> Processing Dependency: lksctp-tools(x86-64) for package: 1:java-1.8.0-openjdk-headless-1.8.0.121-0.b13.el7_3.x86_64
==> centos7_server: --> Processing Dependency: jpackage-utils for package: 1:java-1.8.0-openjdk-headless-1.8.0.121-0.b13.el7_3.x86_64
==> centos7_server: ---> Package libX11.x86_64 0:1.6.3-3.el7 will be installed
==> centos7_server: --> Processing Dependency: libX11-common >= 1.6.3-3.el7 for package: libX11-1.6.3-3.el7.x86_64
==> centos7_server: --> Processing Dependency: libxcb.so.1()(64bit) for package: libX11-1.6.3-3.el7.x86_64
==> centos7_server: ---> Package libXcomposite.x86_64 0:0.4.4-4.1.el7 will be installed
==> centos7_server: ---> Package libXext.x86_64 0:1.3.3-3.el7 will be installed
==> centos7_server: ---> Package libXi.x86_64 0:1.7.4-2.el7 will be installed
==> centos7_server: ---> Package libXrender.x86_64 0:0.9.8-2.1.el7 will be installed
==> centos7_server: ---> Package libXtst.x86_64 0:1.2.2-2.1.el7 will be installed
==> centos7_server: ---> Package libjpeg-turbo.x86_64 0:1.2.90-5.el7 will be installed
==> centos7_server: ---> Package libpng.x86_64 2:1.5.13-7.el7_2 will be installed
==> centos7_server: ---> Package mailcap.noarch 0:2.1.41-2.el7 will be installed
==> centos7_server: ---> Package mod_wsgi.x86_64 0:3.4-12.el7_0 will be installed
==> centos7_server: ---> Package openldap.x86_64 0:2.4.40-9.el7_2 will be updated
==> centos7_server: ---> Package openldap.x86_64 0:2.4.40-13.el7 will be an update
==> centos7_server: ---> Package policycoreutils-python.x86_64 0:2.5-11.el7_3 will be installed
==> centos7_server: --> Processing Dependency: policycoreutils = 2.5-11.el7_3 for package: policycoreutils-python-2.5-11.el7_3.x86_64
==> centos7_server: --> Processing Dependency: setools-libs >= 3.3.8-1 for package: policycoreutils-python-2.5-11.el7_3.x86_64
==> centos7_server: --> Processing Dependency: libsemanage-python >= 2.5-5 for package: policycoreutils-python-2.5-11.el7_3.x86_64
==> centos7_server: --> Processing Dependency: audit-libs-python >= 2.1.3-4 for package: policycoreutils-python-2.5-11.el7_3.x86_64
==> centos7_server: --> Processing Dependency: python-IPy for package: policycoreutils-python-2.5-11.el7_3.x86_64
==> centos7_server: --> Processing Dependency: libsepol.so.1(LIBSEPOL_1.0)(64bit) for package: policycoreutils-python-2.5-11.el7_3.x86_64
==> centos7_server: --> Processing Dependency: libqpol.so.1(VERS_1.4)(64bit) for package: policycoreutils-python-2.5-11.el7_3.x86_64
==> centos7_server: --> Processing Dependency: libqpol.so.1(VERS_1.2)(64bit) for package: policycoreutils-python-2.5-11.el7_3.x86_64
==> centos7_server: --> Processing Dependency: libcgroup for package: policycoreutils-python-2.5-11.el7_3.x86_64
==> centos7_server: --> Processing Dependency: libapol.so.4(VERS_4.0)(64bit) for package: policycoreutils-python-2.5-11.el7_3.x86_64
==> centos7_server: --> Processing Dependency: checkpolicy for package: policycoreutils-python-2.5-11.el7_3.x86_64
==> centos7_server: --> Processing Dependency: libqpol.so.1()(64bit) for package: policycoreutils-python-2.5-11.el7_3.x86_64
==> centos7_server: --> Processing Dependency: libapol.so.4()(64bit) for package: policycoreutils-python-2.5-11.el7_3.x86_64
==> centos7_server: ---> Package postgresql-libs.x86_64 0:9.2.18-1.el7 will be installed
==> centos7_server: ---> Package rsyslog.x86_64 0:7.4.7-12.el7 will be updated
==> centos7_server: ---> Package rsyslog.x86_64 0:7.4.7-16.el7 will be an update
==> centos7_server: ---> Package xorg-x11-fonts-Type1.noarch 0:7.5-9.el7 will be installed
==> centos7_server: --> Processing Dependency: ttmkfdir for package: xorg-x11-fonts-Type1-7.5-9.el7.noarch
==> centos7_server: --> Processing Dependency: ttmkfdir for package: xorg-x11-fonts-Type1-7.5-9.el7.noarch
==> centos7_server: --> Processing Dependency: mkfontdir for package: xorg-x11-fonts-Type1-7.5-9.el7.noarch
==> centos7_server: --> Processing Dependency: mkfontdir for package: xorg-x11-fonts-Type1-7.5-9.el7.noarch
==> centos7_server: --> Running transaction check
==> centos7_server: ---> Package audit-libs-python.x86_64 0:2.6.5-3.el7_3.1 will be installed
==> centos7_server: --> Processing Dependency: audit-libs(x86-64) = 2.6.5-3.el7_3.1 for package: audit-libs-python-2.6.5-3.el7_3.1.x86_64
==> centos7_server: ---> Package checkpolicy.x86_64 0:2.5-4.el7 will be installed
==> centos7_server: ---> Package chkconfig.x86_64 0:1.3.61-5.el7_2.1 will be updated
==> centos7_server: ---> Package chkconfig.x86_64 0:1.7.2-1.el7 will be an update
==> centos7_server: ---> Package copy-jdk-configs.noarch 0:1.2-1.el7 will be installed
==> centos7_server: ---> Package fontpackages-filesystem.noarch 0:1.44-8.el7 will be installed
==> centos7_server: ---> Package javapackages-tools.noarch 0:3.4.1-11.el7 will be installed
==> centos7_server: --> Processing Dependency: python-javapackages = 3.4.1-11.el7 for package: javapackages-tools-3.4.1-11.el7.noarch
==> centos7_server: --> Processing Dependency: libxslt for package: javapackages-tools-3.4.1-11.el7.noarch
==> centos7_server: ---> Package libICE.x86_64 0:1.0.9-2.el7 will be installed
==> centos7_server: ---> Package libSM.x86_64 0:1.2.2-2.el7 will be installed
==> centos7_server: ---> Package libX11-common.noarch 0:1.6.3-3.el7 will be installed
==> centos7_server: ---> Package libcgroup.x86_64 0:0.41-11.el7 will be installed
==> centos7_server: ---> Package libsemanage-python.x86_64 0:2.5-5.1.el7_3 will be installed
==> centos7_server: --> Processing Dependency: libsemanage = 2.5-5.1.el7_3 for package: libsemanage-python-2.5-5.1.el7_3.x86_64
==> centos7_server: --> Processing Dependency: libsemanage.so.1(LIBSEMANAGE_1.1)(64bit) for package: libsemanage-python-2.5-5.1.el7_3.x86_64
==> centos7_server: ---> Package libsepol.x86_64 0:2.1.9-3.el7 will be updated
==> centos7_server: ---> Package libsepol.x86_64 0:2.5-6.el7 will be an update
==> centos7_server: ---> Package libxcb.x86_64 0:1.11-4.el7 will be installed
==> centos7_server: --> Processing Dependency: libXau.so.6()(64bit) for package: libxcb-1.11-4.el7.x86_64
==> centos7_server: ---> Package lksctp-tools.x86_64 0:1.0.17-2.el7 will be installed
==> centos7_server: ---> Package nss.x86_64 0:3.21.0-9.el7_2 will be updated
==> centos7_server: --> Processing Dependency: nss = 3.21.0-9.el7_2 for package: nss-sysinit-3.21.0-9.el7_2.x86_64
==> centos7_server: --> Processing Dependency: nss(x86-64) = 3.21.0-9.el7_2 for package: nss-tools-3.21.0-9.el7_2.x86_64
==> centos7_server: ---> Package nss.x86_64 0:3.28.2-1.6.el7_3 will be an update
==> centos7_server: --> Processing Dependency: nss-util >= 3.28.2-1.1 for package: nss-3.28.2-1.6.el7_3.x86_64
==> centos7_server: --> Processing Dependency: nspr >= 4.13.1 for package: nss-3.28.2-1.6.el7_3.x86_64
==> centos7_server: --> Processing Dependency: libnssutil3.so(NSSUTIL_3.24)(64bit) for package: nss-3.28.2-1.6.el7_3.x86_64
==> centos7_server: ---> Package policycoreutils.x86_64 0:2.2.5-20.el7 will be updated
==> centos7_server: ---> Package policycoreutils.x86_64 0:2.5-11.el7_3 will be an update
==> centos7_server: --> Processing Dependency: libselinux-utils >= 2.5-6 for package: policycoreutils-2.5-11.el7_3.x86_64
==> centos7_server: ---> Package python-IPy.noarch 0:0.75-6.el7 will be installed
==> centos7_server: ---> Package setools-libs.x86_64 0:3.3.8-1.1.el7 will be installed
==> centos7_server: --> Processing Dependency: libselinux >= 2.5-0 for package: setools-libs-3.3.8-1.1.el7.x86_64
==> centos7_server: ---> Package ttmkfdir.x86_64 0:3.0.9-42.el7 will be installed
==> centos7_server: ---> Package tzdata-java.noarch 0:2017a-1.el7 will be installed
==> centos7_server: ---> Package xorg-x11-font-utils.x86_64 1:7.5-20.el7 will be installed
==> centos7_server: --> Processing Dependency: libfontenc.so.1()(64bit) for package: 1:xorg-x11-font-utils-7.5-20.el7.x86_64
==> centos7_server: --> Processing Dependency: libXfont.so.1()(64bit) for package: 1:xorg-x11-font-utils-7.5-20.el7.x86_64
==> centos7_server: --> Running transaction check
==> centos7_server: ---> Package audit-libs.x86_64 0:2.4.1-5.el7 will be updated
==> centos7_server: --> Processing Dependency: audit-libs = 2.4.1-5.el7 for package: audit-2.4.1-5.el7.x86_64
==> centos7_server: ---> Package audit-libs.x86_64 0:2.6.5-3.el7_3.1 will be an update
==> centos7_server: ---> Package libXau.x86_64 0:1.0.8-2.1.el7 will be installed
==> centos7_server: ---> Package libXfont.x86_64 0:1.5.1-2.el7 will be installed
==> centos7_server: ---> Package libfontenc.x86_64 0:1.1.2-3.el7 will be installed
==> centos7_server: ---> Package libselinux.x86_64 0:2.2.2-6.el7 will be updated
==> centos7_server: --> Processing Dependency: libselinux = 2.2.2-6.el7 for package: libselinux-python-2.2.2-6.el7.x86_64
==> centos7_server: ---> Package libselinux.x86_64 0:2.5-6.el7 will be an update
==> centos7_server: ---> Package libselinux-utils.x86_64 0:2.2.2-6.el7 will be updated
==> centos7_server: ---> Package libselinux-utils.x86_64 0:2.5-6.el7 will be an update
==> centos7_server: ---> Package libsemanage.x86_64 0:2.1.10-18.el7 will be updated
==> centos7_server: ---> Package libsemanage.x86_64 0:2.5-5.1.el7_3 will be an update
==> centos7_server: ---> Package libxslt.x86_64 0:1.1.28-5.el7 will be installed
==> centos7_server: ---> Package nspr.x86_64 0:4.11.0-1.el7_2 will be updated
==> centos7_server: ---> Package nspr.x86_64 0:4.13.1-1.0.el7_3 will be an update
==> centos7_server: ---> Package nss-sysinit.x86_64 0:3.21.0-9.el7_2 will be updated
==> centos7_server: ---> Package nss-sysinit.x86_64 0:3.28.2-1.6.el7_3 will be an update
==> centos7_server: ---> Package nss-tools.x86_64 0:3.21.0-9.el7_2 will be updated
==> centos7_server: ---> Package nss-tools.x86_64 0:3.28.2-1.6.el7_3 will be an update
==> centos7_server: ---> Package nss-util.x86_64 0:3.21.0-2.2.el7_2 will be updated
==> centos7_server: ---> Package nss-util.x86_64 0:3.28.2-1.1.el7_3 will be an update
==> centos7_server: ---> Package python-javapackages.noarch 0:3.4.1-11.el7 will be installed
==> centos7_server: --> Processing Dependency: python-lxml for package: python-javapackages-3.4.1-11.el7.noarch
==> centos7_server: --> Running transaction check
==> centos7_server: ---> Package audit.x86_64 0:2.4.1-5.el7 will be updated
==> centos7_server: ---> Package audit.x86_64 0:2.6.5-3.el7_3.1 will be an update
==> centos7_server: ---> Package libselinux-python.x86_64 0:2.2.2-6.el7 will be updated
==> centos7_server: ---> Package libselinux-python.x86_64 0:2.5-6.el7 will be an update
==> centos7_server: ---> Package python-lxml.x86_64 0:3.2.1-4.el7 will be installed
==> centos7_server: --> Processing Conflict: libselinux-2.5-6.el7.x86_64 conflicts systemd < 219-20
==> centos7_server: --> Restarting Dependency Resolution with new changes.
==> centos7_server: --> Running transaction check
==> centos7_server: ---> Package systemd.x86_64 0:219-19.el7_2.11 will be updated
==> centos7_server: --> Processing Dependency: systemd = 219-19.el7_2.11 for package: systemd-sysv-219-19.el7_2.11.x86_64
==> centos7_server: ---> Package systemd.x86_64 0:219-30.el7_3.7 will be an update
==> centos7_server: --> Processing Dependency: systemd-libs = 219-30.el7_3.7 for package: systemd-219-30.el7_3.7.x86_64
==> centos7_server: --> Running transaction check
==> centos7_server: ---> Package systemd-libs.x86_64 0:219-19.el7_2.11 will be updated
==> centos7_server: --> Processing Dependency: systemd-libs = 219-19.el7_2.11 for package: libgudev1-219-19.el7_2.11.x86_64
==> centos7_server: ---> Package systemd-libs.x86_64 0:219-30.el7_3.7 will be an update
==> centos7_server: ---> Package systemd-sysv.x86_64 0:219-19.el7_2.11 will be updated
==> centos7_server: ---> Package systemd-sysv.x86_64 0:219-30.el7_3.7 will be an update
==> centos7_server: --> Running transaction check
==> centos7_server: ---> Package libgudev1.x86_64 0:219-19.el7_2.11 will be updated
==> centos7_server: ---> Package libgudev1.x86_64 0:219-30.el7_3.7 will be an update
==> centos7_server: --> Processing Conflict: libsemanage-2.5-5.1.el7_3.x86_64 conflicts selinux-policy-base < 3.13.1-66
==> centos7_server: --> Restarting Dependency Resolution with new changes.
==> centos7_server: --> Running transaction check
==> centos7_server: ---> Package selinux-policy-targeted.noarch 0:3.13.1-60.el7_2.7 will be updated
==> centos7_server: ---> Package selinux-policy-targeted.noarch 0:3.13.1-102.el7_3.15 will be an update
==> centos7_server: --> Processing Dependency: selinux-policy = 3.13.1-102.el7_3.15 for package: selinux-policy-targeted-3.13.1-102.el7_3.15.noarch
==> centos7_server: --> Processing Dependency: selinux-policy = 3.13.1-102.el7_3.15 for package: selinux-policy-targeted-3.13.1-102.el7_3.15.noarch
==> centos7_server: --> Running transaction check
==> centos7_server: ---> Package selinux-policy.noarch 0:3.13.1-60.el7_2.7 will be updated
==> centos7_server: ---> Package selinux-policy.noarch 0:3.13.1-102.el7_3.15 will be an update
==> centos7_server: --> Finished Dependency Resolution
==> centos7_server: 
==> centos7_server: Dependencies Resolved
==> centos7_server: 
==> centos7_server: ================================================================================
==> centos7_server:  Package                     Arch   Version                       Repository
==> centos7_server:                                                                            Size
==> centos7_server: ================================================================================
==> centos7_server: Installing:
==> centos7_server:  rudder-server-root          noarch 1398866025:4.0.4.rc1.git201703220317-1.EL.7
==> centos7_server:                                                                   Rudder  4.9 k
==> centos7_server: Updating:
==> centos7_server:  selinux-policy-targeted     noarch 3.13.1-102.el7_3.15           updates 6.4 M
==> centos7_server:  systemd                     x86_64 219-30.el7_3.7                updates 5.2 M
==> centos7_server: Installing for dependencies:
==> centos7_server:  apr                         x86_64 1.4.8-3.el7                   base    103 k
==> centos7_server:  apr-util                    x86_64 1.5.2-6.el7                   base     92 k
==> centos7_server:  audit-libs-python           x86_64 2.6.5-3.el7_3.1               updates  70 k
==> centos7_server:  checkpolicy                 x86_64 2.5-4.el7                     base    290 k
==> centos7_server:  copy-jdk-configs            noarch 1.2-1.el7                     base     14 k
==> centos7_server:  fontconfig                  x86_64 2.10.95-10.el7                base    229 k
==> centos7_server:  fontpackages-filesystem     noarch 1.44-8.el7                    base    9.9 k
==> centos7_server:  giflib                      x86_64 4.1.6-9.el7                   base     40 k
==> centos7_server:  httpd                       x86_64 2.4.6-45.el7.centos           base    2.7 M
==> centos7_server:  httpd-tools                 x86_64 2.4.6-45.el7.centos           base     84 k
==> centos7_server:  java-1.8.0-openjdk          x86_64 1:1.8.0.121-0.b13.el7_3       updates 232 k
==> centos7_server:  java-1.8.0-openjdk-headless x86_64 1:1.8.0.121-0.b13.el7_3       updates  31 M
==> centos7_server:  javapackages-tools          noarch 3.4.1-11.el7                  base     73 k
==> centos7_server:  libICE                      x86_64 1.0.9-2.el7                   base     65 k
==> centos7_server:  libSM                       x86_64 1.2.2-2.el7                   base     39 k
==> centos7_server:  libX11                      x86_64 1.6.3-3.el7                   base    606 k
==> centos7_server:  libX11-common               noarch 1.6.3-3.el7                   base    162 k
==> centos7_server:  libXau                      x86_64 1.0.8-2.1.el7                 base     29 k
==> centos7_server:  libXcomposite               x86_64 0.4.4-4.1.el7                 base     22 k
==> centos7_server:  libXext                     x86_64 1.3.3-3.el7                   base     39 k
==> centos7_server:  libXfont                    x86_64 1.5.1-2.el7                   base    150 k
==> centos7_server:  libXi                       x86_64 1.7.4-2.el7                   base     40 k
==> centos7_server:  libXrender                  x86_64 0.9.8-2.1.el7                 base     25 k
==> centos7_server:  libXtst                     x86_64 1.2.2-2.1.el7                 base     20 k
==> centos7_server:  libcgroup                   x86_64 0.41-11.el7                   base     65 k
==> centos7_server:  libfontenc                  x86_64 1.1.2-3.el7                   base     30 k
==> centos7_server:  libjpeg-turbo               x86_64 1.2.90-5.el7                  base    134 k
==> centos7_server:  libpng                      x86_64 2:1.5.13-7.el7_2              base    213 k
==> centos7_server:  libsemanage-python          x86_64 2.5-5.1.el7_3                 updates 104 k
==> centos7_server:  libtool-ltdl                x86_64 2.4.2-21.el7_2                base     49 k
==> centos7_server:  libxcb                      x86_64 1.11-4.el7                    base    189 k
==> centos7_server:  libxslt                     x86_64 1.1.28-5.el7                  base    242 k
==> centos7_server:  lksctp-tools                x86_64 1.0.17-2.el7                  base     88 k
==> centos7_server:  mailcap                     noarch 2.1.41-2.el7                  base     31 k
==> centos7_server:  mod_ssl                     x86_64 1:2.4.6-45.el7.centos         base    105 k
==> centos7_server:  mod_wsgi                    x86_64 3.4-12.el7_0                  base     76 k
==> centos7_server:  ncf                         noarch 1398866025:1.0.0.201703220427-1.EL.7
==> centos7_server:                                                                   Rudder  1.4 M
==> centos7_server:  ncf-api-virtualenv          noarch 1398866025:4.0.4.rc1.git201703220317-1.EL.7
==> centos7_server:                                                                   Rudder  3.7 M
==> centos7_server:  net-tools                   x86_64 2.0-0.17.20131004git.el7      base    304 k
==> centos7_server:  openldap-clients            x86_64 2.4.40-13.el7                 base    188 k
==> centos7_server:  policycoreutils-python      x86_64 2.5-11.el7_3                  updates 445 k
==> centos7_server:  postgresql                  x86_64 9.2.18-1.el7                  base    3.0 M
==> centos7_server:  postgresql-libs             x86_64 9.2.18-1.el7                  base    232 k
==> centos7_server:  postgresql-server           x86_64 9.2.18-1.el7                  base    3.8 M
==> centos7_server:  python-IPy                  noarch 0.75-6.el7                    base     32 k
==> centos7_server:  python-javapackages         noarch 3.4.1-11.el7                  base     31 k
==> centos7_server:  python-lxml                 x86_64 3.2.1-4.el7                   base    758 k
==> centos7_server:  rsyslog-pgsql               x86_64 7.4.7-16.el7                  base     30 k
==> centos7_server:  rudder-agent                i686   1398866025:4.0.4.rc1.git201703220447-1.EL.7
==> centos7_server:                                                                   Rudder   22 M
==> centos7_server:  rudder-inventory-endpoint   noarch 1398866025:4.0.4.rc1.git201703220317-1.EL.7
==> centos7_server:                                                                   Rudder   39 M
==> centos7_server:  rudder-inventory-ldap       x86_64 1398866025:4.0.4.rc1.git201703220317-1.EL.7
==> centos7_server:                                                                   Rudder  5.7 M
==> centos7_server:  rudder-jetty                noarch 1398866025:4.0.4.rc1.git201703220317-1.EL.7
==> centos7_server:                                                                   Rudder  5.4 M
==> centos7_server:  rudder-reports              noarch 1398866025:4.0.4.rc1.git201703220317-1.EL.7
==> centos7_server:                                                                   Rudder   11 k
==> centos7_server:  rudder-techniques           noarch 1398866025:4.0.4.rc1.git201703220317-1.EL.7
==> centos7_server:                                                                   Rudder   18 M
==> centos7_server:  rudder-webapp               noarch 1398866025:4.0.4.rc1.git201703220317-1.EL.7
==> centos7_server:                                                                   Rudder  100 M
==> centos7_server:  setools-libs                x86_64 3.3.8-1.1.el7                 base    612 k
==> centos7_server:  ttmkfdir                    x86_64 3.0.9-42.el7                  base     48 k
==> centos7_server:  tzdata-java                 noarch 2017a-1.el7                   updates 182 k
==> centos7_server:  xorg-x11-font-utils         x86_64 1:7.5-20.el7                  base     87 k
==> centos7_server:  xorg-x11-fonts-Type1        noarch 7.5-9.el7                     base    521 k
==> centos7_server: Updating for dependencies:
==> centos7_server:  audit                       x86_64 2.6.5-3.el7_3.1               updates 233 k
==> centos7_server:  audit-libs                  x86_64 2.6.5-3.el7_3.1               updates  85 k
==> centos7_server:  chkconfig                   x86_64 1.7.2-1.el7                   base    175 k
==> centos7_server:  libgudev1                   x86_64 219-30.el7_3.7                updates  76 k
==> centos7_server:  libselinux                  x86_64 2.5-6.el7                     base    161 k
==> centos7_server:  libselinux-python           x86_64 2.5-6.el7                     base    234 k
==> centos7_server:  libselinux-utils            x86_64 2.5-6.el7                     base    151 k
==> centos7_server:  libsemanage                 x86_64 2.5-5.1.el7_3                 updates 144 k
==> centos7_server:  libsepol                    x86_64 2.5-6.el7                     base    288 k
==> centos7_server:  nspr                        x86_64 4.13.1-1.0.el7_3              updates 126 k
==> centos7_server:  nss                         x86_64 3.28.2-1.6.el7_3              updates 873 k
==> centos7_server:  nss-sysinit                 x86_64 3.28.2-1.6.el7_3              updates  58 k
==> centos7_server:  nss-tools                   x86_64 3.28.2-1.6.el7_3              updates 496 k
==> centos7_server:  nss-util                    x86_64 3.28.2-1.1.el7_3              updates  73 k
==> centos7_server:  openldap                    x86_64 2.4.40-13.el7                 base    350 k
==> centos7_server:  policycoreutils             x86_64 2.5-11.el7_3                  updates 841 k
==> centos7_server:  rsyslog                     x86_64 7.4.7-16.el7                  base    573 k
==> centos7_server:  selinux-policy              noarch 3.13.1-102.el7_3.15           updates 414 k
==> centos7_server:  systemd-libs                x86_64 219-30.el7_3.7                updates 369 k
==> centos7_server:  systemd-sysv                x86_64 219-30.el7_3.7                updates  63 k
==> centos7_server: 
==> centos7_server: Transaction Summary
==> centos7_server: ================================================================================
==> centos7_server: Install  1 Package  (+60 Dependent packages)
==> centos7_server: Upgrade  2 Packages (+20 Dependent packages)
==> centos7_server: Total download size: 261 M
==> centos7_server: Downloading packages:
==> centos7_server: Delta RPMs disabled because /usr/bin/applydeltarpm not installed.
==> centos7_server: --------------------------------------------------------------------------------
==> centos7_server: Total                                              1.3 MB/s | 261 MB  03:20     
==> centos7_server: Running transaction check
==> centos7_server: Running transaction test
==> centos7_server: Transaction test succeeded
==> centos7_server: Running transaction
==> centos7_server:   Updating   : libsepol-2.5-6.el7.x86_64                                  1/105
==> centos7_server:  
==> centos7_server:   Updating   : libselinux-2.5-6.el7.x86_64                                2/105
==> centos7_server:  
==> centos7_server:   Updating   : nspr-4.13.1-1.0.el7_3.x86_64                               3/105
==> centos7_server:  
==> centos7_server:   Updating   : nss-util-3.28.2-1.1.el7_3.x86_64                           4/105
==> centos7_server:  
==> centos7_server:   Updating   : audit-libs-2.6.5-3.el7_3.1.x86_64                          5/105
==> centos7_server:  
==> centos7_server:   Updating   : systemd-libs-219-30.el7_3.7.x86_64                         6/105
==> centos7_server:  
==> centos7_server:   Updating   : systemd-219-30.el7_3.7.x86_64                              7/105
==> centos7_server:  
==> centos7_server:   Updating   : chkconfig-1.7.2-1.el7.x86_64                               8/105
==> centos7_server:  
==> centos7_server:   Updating   : nss-3.28.2-1.6.el7_3.x86_64                                9/105
==> centos7_server:  
==> centos7_server:   Updating   : nss-sysinit-3.28.2-1.6.el7_3.x86_64                       10/105
==> centos7_server:  
==> centos7_server:   Updating   : rsyslog-7.4.7-16.el7.x86_64                               11/105
==> centos7_server:  
==> centos7_server:   Updating   : libsemanage-2.5-5.1.el7_3.x86_64                          12/105
==> centos7_server:  
==> centos7_server:   Installing : apr-1.4.8-3.el7.x86_64                                    13/105
==> centos7_server:  
==> centos7_server:   Installing : 1398866025:ncf-1.0.0.201703220427-1.EL.7.noarch           14/105
==> centos7_server:  
==> centos7_server:   Installing : apr-util-1.5.2-6.el7.x86_64                               15/105
==> centos7_server:  
==> centos7_server:   Installing : httpd-tools-2.4.6-45.el7.centos.x86_64                    16/105
==> centos7_server:  
==> centos7_server:   Updating   : systemd-sysv-219-30.el7_3.7.x86_64                        17/105
==> centos7_server:  
==> centos7_server:   Installing : libfontenc-1.1.2-3.el7.x86_64                             18/105
==> centos7_server:  
==> centos7_server:   Installing : libICE-1.0.9-2.el7.x86_64                                 19/105
==> centos7_server:  
==> centos7_server:   Installing : libxslt-1.1.28-5.el7.x86_64                               20/105
==> centos7_server:  
==> centos7_server:   Installing : libjpeg-turbo-1.2.90-5.el7.x86_64                         21/105
==> centos7_server:  
==> centos7_server:   Installing : python-lxml-3.2.1-4.el7.x86_64                            22/105
==> centos7_server:  
==> centos7_server:   Installing : python-javapackages-3.4.1-11.el7.noarch                   23/105
==> centos7_server:  
==> centos7_server:   Installing : javapackages-tools-3.4.1-11.el7.noarch                    24/105
==> centos7_server:  
==> centos7_server:   Installing : libSM-1.2.2-2.el7.x86_64                                  25/105
==> centos7_server:  
==> centos7_server:   Installing : libXfont-1.5.1-2.el7.x86_64                               26/105
==> centos7_server:  
==> centos7_server:   Installing : 1:xorg-x11-font-utils-7.5-20.el7.x86_64                   27/105
==> centos7_server:  
==> centos7_server:   Installing : 1398866025:rudder-techniques-4.0.4.rc1.git201703220317    28/105
==> centos7_server:  
==> centos7_server:   Installing : libsemanage-python-2.5-5.1.el7_3.x86_64                   29/105
==> centos7_server:  
==> centos7_server:   Updating   : nss-tools-3.28.2-1.6.el7_3.x86_64                         30/105
==> centos7_server:  
==> centos7_server:   Updating   : openldap-2.4.40-13.el7.x86_64                             31/105
==> centos7_server:  
==> centos7_server:   Installing : postgresql-libs-9.2.18-1.el7.x86_64                       32/105
==> centos7_server:  
==> centos7_server:   Installing : postgresql-9.2.18-1.el7.x86_64                            33/105
==> centos7_server:  
==> centos7_server:   Installing : postgresql-server-9.2.18-1.el7.x86_64                     34/105
==> centos7_server:  
==> centos7_server:   Installing : rsyslog-pgsql-7.4.7-16.el7.x86_64                         35/105
==> centos7_server:  
==> centos7_server: ● postgresql.service - PostgreSQL database server
==> centos7_server:    Loaded: loaded (/usr/lib/systemd/system/postgresql.service; disabled; vendor preset: disabled)
==> centos7_server:    Active: inactive (dead)
==> centos7_server: Hint: the preferred way to do this is now "postgresql-setup initdb" 
==> centos7_server: Initializing database ... OK
==> centos7_server:   Installing : 1398866025:rudder-reports-4.0.4.rc1.git201703220317-1.    36/105
==> centos7_server:  
==> centos7_server: INFO: Setting PostgreSQL as a boot service... Done
==> centos7_server: INFO: Waiting for PostgreSQL to be up... Done
==> centos7_server: INFO: Creating Rudder PostgreSQL user... Done
==> centos7_server: INFO: Creating Rudder PostgreSQL database... Done
==> centos7_server:   Installing : openldap-clients-2.4.40-13.el7.x86_64                     37/105
==> centos7_server:  
==> centos7_server:   Installing : libcgroup-0.41-11.el7.x86_64                              38/105
==> centos7_server:  
==> centos7_server:   Installing : net-tools-2.0-0.17.20131004git.el7.x86_64                 39/105
==> centos7_server:  
==> centos7_server:   Installing : 1398866025:rudder-agent-4.0.4.rc1.git201703220447-1.EL    40/105
==> centos7_server:  
==> centos7_server: ok: Rudder agent is now disabled.
==> centos7_server: INFO: Ensuring correct permissions on the keys directory... Done.
==> centos7_server: INFO: Creating keys for CFEngine agent...warning: %post(rudder-agent-1398866025:4.0.4.rc1.git201703220447-1.EL.7.i686) scriptlet failed, exit status 126
==> centos7_server: Non-fatal POSTIN scriptlet failure in rpm package 1398866025:rudder-agent-4.0.4.rc1.git201703220447-1.EL.7.i686
==> centos7_server:   Installing : audit-libs-python-2.6.5-3.el7_3.1.x86_64                  41/105
==> centos7_server:  
==> centos7_server:   Updating   : libselinux-python-2.5-6.el7.x86_64                        42/105
==> centos7_server:  
==> centos7_server:   Updating   : libselinux-utils-2.5-6.el7.x86_64                         43/105
==> centos7_server:  
==> centos7_server:   Updating   : policycoreutils-2.5-11.el7_3.x86_64                       44/105
==> centos7_server:  
==> centos7_server:   Updating   : selinux-policy-3.13.1-102.el7_3.15.noarch                 45/105
==> centos7_server:  
==> centos7_server:   Installing : setools-libs-3.3.8-1.1.el7.x86_64                         46/105
==> centos7_server:  
==> centos7_server:   Installing : copy-jdk-configs-1.2-1.el7.noarch                         47/105
==> centos7_server:  
==> centos7_server:   Installing : libtool-ltdl-2.4.2-21.el7_2.x86_64                        48/105
==> centos7_server:  
==> centos7_server:   Installing : 1398866025:rudder-inventory-ldap-4.0.4.rc1.git20170322    49/105
==> centos7_server:  
==> centos7_server: INFO: Setting rudder-slapd as a boot service... Done
==> centos7_server: INFO: Reloading syslogd...  Done
==> centos7_server: INFO: Restarting rudder-slapd... Done
==> centos7_server:   Installing : tzdata-java-2017a-1.el7.noarch                            50/105
==> centos7_server:  
==> centos7_server:   Installing : ttmkfdir-3.0.9-42.el7.x86_64                              51/105
==> centos7_server:  
==> centos7_server:   Installing : fontpackages-filesystem-1.44-8.el7.noarch                 52/105
==> centos7_server:  
==> centos7_server:   Installing : fontconfig-2.10.95-10.el7.x86_64                          53/105
==> centos7_server:  
==> centos7_server:   Installing : xorg-x11-fonts-Type1-7.5-9.el7.noarch                     54/105
==> centos7_server:  
==> centos7_server:   Installing : mailcap-2.1.41-2.el7.noarch                               55/105
==> centos7_server:  
==> centos7_server:   Installing : httpd-2.4.6-45.el7.centos.x86_64                          56/105
==> centos7_server:  
==> centos7_server:   Installing : mod_wsgi-3.4-12.el7_0.x86_64                              57/105
==> centos7_server:  
==> centos7_server:   Installing : 1:mod_ssl-2.4.6-45.el7.centos.x86_64                      58/105
==> centos7_server:  
==> centos7_server:   Installing : checkpolicy-2.5-4.el7.x86_64                              59/105
==> centos7_server:  
==> centos7_server:   Installing : libX11-common-1.6.3-3.el7.noarch                          60/105
==> centos7_server:  
==> centos7_server:   Installing : python-IPy-0.75-6.el7.noarch                              61/105
==> centos7_server:  
==> centos7_server:   Installing : policycoreutils-python-2.5-11.el7_3.x86_64                62/105
==> centos7_server:  
==> centos7_server: INFO: Creating the ncf-api-venv user... Done
==> centos7_server:   Installing : 1398866025:ncf-api-virtualenv-4.0.4.rc1.git20170322031    63/105
==> centos7_server:  
==> centos7_server: INFO: Applying ncf-api-virtualenv selinux policy...Failed to resolve typeattributeset statement at /etc/selinux/targeted/tmp/modules/400/ncf-api-virtualenv/cil:1
==> centos7_server: semodule:  Failed!
==> centos7_server: libsemanage.semanage_read_policydb: Could not open kernel policy /etc/selinux/targeted/active/policy.kern for reading. (No such file or directory).
==> centos7_server: OSError: No such file or directory
==> centos7_server:  Done
==> centos7_server:   Installing : libXau-1.0.8-2.1.el7.x86_64                               64/105
==> centos7_server:  
==> centos7_server:   Installing : libxcb-1.11-4.el7.x86_64                                  65/105
==> centos7_server:  
==> centos7_server:   Installing : libX11-1.6.3-3.el7.x86_64                                 66/105
==> centos7_server:  
==> centos7_server:   Installing : libXext-1.3.3-3.el7.x86_64                                67/105
==> centos7_server:  
==> centos7_server:   Installing : libXi-1.7.4-2.el7.x86_64                                  68/105
==> centos7_server:  
==> centos7_server:   Installing : libXtst-1.2.2-2.1.el7.x86_64                              69/105
==> centos7_server:  
==> centos7_server:   Installing : libXcomposite-0.4.4-4.1.el7.x86_64                        70/105
==> centos7_server:  
==> centos7_server:   Installing : giflib-4.1.6-9.el7.x86_64                                 71/105
==> centos7_server:  
==> centos7_server:   Installing : libXrender-0.9.8-2.1.el7.x86_64                           72/105
==> centos7_server:  
==> centos7_server:   Installing : lksctp-tools-1.0.17-2.el7.x86_64                          73/105
==> centos7_server:  
==> centos7_server:   Installing : 1:java-1.8.0-openjdk-headless-1.8.0.121-0.b13.el7_3.x8    74/105
==> centos7_server:  
==> centos7_server:   Installing : 2:libpng-1.5.13-7.el7_2.x86_64                            75/105
==> centos7_server:  
==> centos7_server:   Installing : 1:java-1.8.0-openjdk-1.8.0.121-0.b13.el7_3.x86_64         76/105
==> centos7_server:  
==> centos7_server:   Installing : 1398866025:rudder-jetty-4.0.4.rc1.git201703220317-1.EL    77/105
==> centos7_server:  
==> centos7_server:   Installing : 1398866025:rudder-inventory-endpoint-4.0.4.rc1.git2017    78/105
==> centos7_server:  
==> centos7_server: INFO: Launching script to check if a migration is needed
==> centos7_server: INFO: End of migration script
==> centos7_server: INFO: Restarting syslogd ... Done
==> centos7_server:   Installing : 1398866025:rudder-webapp-4.0.4.rc1.git201703220317-1.E    79/105
==> centos7_server:  
==> centos7_server: INFO: Setting Apache HTTPd as a boot service...Created symlink from /etc/systemd/system/multi-user.target.wants/httpd.service to /usr/lib/systemd/system/httpd.service.
==> centos7_server:  Done
==> centos7_server: INFO: Restarting syslog... Done
==> centos7_server: INFO: Stopping Apache HTTPd... Done
==> centos7_server: INFO: Creating group rudder... Done
==> centos7_server: INFO: Adding ncf-api-venv to the rudder group... Done
==> centos7_server: INFO: No usable SSL certificate detected for Rudder HTTP/S support, generating one automatically... Done
==> centos7_server: Failed to resolve typeattributeset statement at /etc/selinux/targeted/tmp/modules/400/rudder-webapp/cil:1
==> centos7_server: semodule:  Failed!
==> centos7_server: INFO: Starting Apache HTTPd... Done
==> centos7_server: INFO: Launching script to check if a migration is needed
==> centos7_server: INFO: Checking if rudder-web.properties database access credentials are all right... LDAP OK,  SQL Credentials updated
==> centos7_server: INFO: Checking if inventory-web.properties database access credentials are all right... LDAP OK,  SQL skipped
==> centos7_server: INFO: Checking PostgreSQL service status... OK
==> centos7_server: INFO: Checking LDAP service status... OK
==> centos7_server: 
==> centos7_server: INFO: The migration has completed successfully.
==> centos7_server: INFO: End of migration script
==> centos7_server: libsemanage.semanage_read_policydb: Could not open kernel policy /etc/selinux/targeted/active/policy.kern for reading. (No such file or directory).
==> centos7_server: OSError: No such file or directory
==> centos7_server: Initialized empty shared Git repository in /var/rudder/configuration-repository/.git/
==> centos7_server: ********************************************************************************
==> centos7_server: rudder-webapp has been upgraded, but for the upgrade to take effect, please
==> centos7_server: restart the jetty application server as follows:
==> centos7_server: # service rudder-jetty restart
==> centos7_server: ********************************************************************************
==> centos7_server:   Installing : 1398866025:rudder-server-root-4.0.4.rc1.git20170322031    80/105
==> centos7_server:  
==> centos7_server: ************************************************************
==> centos7_server: Rudder is now installed but not configured.
==> centos7_server: Please run /opt/rudder/bin/rudder-init
==> centos7_server: ************************************************************
==> centos7_server:   Updating   : selinux-policy-targeted-3.13.1-102.el7_3.15.noarch        81/105
==> centos7_server:  
==> centos7_server: warning: /etc/selinux/targeted/seusers created as /etc/selinux/targeted/seusers.rpmnew
==> centos7_server: ‘/etc/selinux/targeted/modules/active/seusers’ -> ‘/etc/selinux/targeted/active/seusers.local’
==> centos7_server:   Updating   : audit-2.6.5-3.el7_3.1.x86_64                              82/105
==> centos7_server:  
==> centos7_server:   Updating   : libgudev1-219-30.el7_3.7.x86_64                           83/105
==> centos7_server:  
==> centos7_server:   Cleanup    : openldap-2.4.40-9.el7_2.x86_64                            84/105
==> centos7_server:  
==> centos7_server:   Cleanup    : nss-tools-3.21.0-9.el7_2.x86_64                           85/105
==> centos7_server:  
==> centos7_server:   Cleanup    : nss-3.21.0-9.el7_2.x86_64                                 86/105
==> centos7_server:  
==> centos7_server:   Cleanup    : nss-sysinit-3.21.0-9.el7_2.x86_64                         87/105
==> centos7_server:  
==> centos7_server:   Cleanup    : audit-2.4.1-5.el7.x86_64                                  88/105
==> centos7_server:  
==> centos7_server:   Cleanup    : selinux-policy-targeted-3.13.1-60.el7_2.7.noarch          89/105
==> centos7_server:  
==> centos7_server: warning: /etc/selinux/targeted/modules/active/seusers.final saved as /etc/selinux/targeted/modules/active/seusers.final.rpmsave
==> centos7_server:   Cleanup    : chkconfig-1.3.61-5.el7_2.1.x86_64                         90/105
==> centos7_server:  
==> centos7_server:   Cleanup    : rsyslog-7.4.7-12.el7.x86_64                               91/105
==> centos7_server:  
==> centos7_server:   Cleanup    : selinux-policy-3.13.1-60.el7_2.7.noarch                   92/105
==> centos7_server:  
==> centos7_server:   Cleanup    : systemd-sysv-219-19.el7_2.11.x86_64                       93/105
==> centos7_server:  
==> centos7_server:   Cleanup    : policycoreutils-2.2.5-20.el7.x86_64                       94/105
==> centos7_server:  
==> centos7_server:   Cleanup    : libsemanage-2.1.10-18.el7.x86_64                          95/105
==> centos7_server:  
==> centos7_server:   Cleanup    : systemd-219-19.el7_2.11.x86_64                            96/105
==> centos7_server:  
==> centos7_server:   Cleanup    : libselinux-utils-2.2.2-6.el7.x86_64                       97/105
==> centos7_server:  
==> centos7_server:   Cleanup    : nss-util-3.21.0-2.2.el7_2.x86_64                          98/105
==> centos7_server:  
==> centos7_server:   Cleanup    : libgudev1-219-19.el7_2.11.x86_64                          99/105
==> centos7_server:  
==> centos7_server:   Cleanup    : systemd-libs-219-19.el7_2.11.x86_64                      100/105
==> centos7_server:  
==> centos7_server:   Cleanup    : libselinux-python-2.2.2-6.el7.x86_64                     101/105
==> centos7_server:  
==> centos7_server:   Cleanup    : libselinux-2.2.2-6.el7.x86_64                            102/105
==> centos7_server:  
==> centos7_server:   Cleanup    : libsepol-2.1.9-3.el7.x86_64                              103/105
==> centos7_server:  
==> centos7_server:   Cleanup    : nspr-4.11.0-1.el7_2.x86_64                               104/105
==> centos7_server:  
==> centos7_server:   Cleanup    : audit-libs-2.4.1-5.el7.x86_64                            105/105
==> centos7_server:  
==> centos7_server:   Verifying  : libXext-1.3.3-3.el7.x86_64                                 1/105
==> centos7_server:  
==> centos7_server:   Verifying  : rsyslog-pgsql-7.4.7-16.el7.x86_64                          2/105
==> centos7_server:  
==> centos7_server:   Verifying  : libXtst-1.2.2-2.1.el7.x86_64                               3/105
==> centos7_server:  
==> centos7_server:   Verifying  : python-lxml-3.2.1-4.el7.x86_64                             4/105
==> centos7_server:  
==> centos7_server:   Verifying  : nss-sysinit-3.28.2-1.6.el7_3.x86_64                        5/105
==> centos7_server:  
==> centos7_server:   Verifying  : 2:libpng-1.5.13-7.el7_2.x86_64                             6/105
==> centos7_server:  
==> centos7_server:   Verifying  : policycoreutils-python-2.5-11.el7_3.x86_64                 7/105
==> centos7_server:  
==> centos7_server:   Verifying  : audit-2.6.5-3.el7_3.1.x86_64                               8/105
==> centos7_server:  
==> centos7_server:   Verifying  : postgresql-server-9.2.18-1.el7.x86_64                      9/105
==> centos7_server:  
==> centos7_server:   Verifying  : python-javapackages-3.4.1-11.el7.noarch                   10/105
==> centos7_server:  
==> centos7_server:   Verifying  : libXcomposite-0.4.4-4.1.el7.x86_64                        11/105
==> centos7_server:  
==> centos7_server:   Verifying  : lksctp-tools-1.0.17-2.el7.x86_64                          12/105
==> centos7_server:  
==> centos7_server:   Verifying  : libsepol-2.5-6.el7.x86_64                                 13/105
==> centos7_server:  
==> centos7_server:   Verifying  : mod_wsgi-3.4-12.el7_0.x86_64                              14/105
==> centos7_server:  
==> centos7_server:   Verifying  : apr-util-1.5.2-6.el7.x86_64                               15/105
==> centos7_server:  
==> centos7_server:   Verifying  : systemd-libs-219-30.el7_3.7.x86_64                        16/105
==> centos7_server:  
==> centos7_server:   Verifying  : libXau-1.0.8-2.1.el7.x86_64                               17/105
==> centos7_server:  
==> centos7_server:   Verifying  : 1398866025:rudder-reports-4.0.4.rc1.git201703220317-1.    18/105
==> centos7_server:  
==> centos7_server:   Verifying  : libX11-1.6.3-3.el7.x86_64                                 19/105
==> centos7_server:  
==> centos7_server:   Verifying  : libcgroup-0.41-11.el7.x86_64                              20/105
==> centos7_server:  
==> centos7_server:   Verifying  : 1:xorg-x11-font-utils-7.5-20.el7.x86_64                   21/105
==> centos7_server:  
==> centos7_server:   Verifying  : giflib-4.1.6-9.el7.x86_64                                 22/105
==> centos7_server:  
==> centos7_server:   Verifying  : 1398866025:rudder-inventory-endpoint-4.0.4.rc1.git2017    23/105
==> centos7_server:  
==> centos7_server:   Verifying  : libxcb-1.11-4.el7.x86_64                                  24/105
==> centos7_server:  
==> centos7_server:   Verifying  : nss-util-3.28.2-1.1.el7_3.x86_64                          25/105
==> centos7_server:  
==> centos7_server:   Verifying  : rsyslog-7.4.7-16.el7.x86_64                               26/105
==> centos7_server:  
==> centos7_server:   Verifying  : python-IPy-0.75-6.el7.noarch                              27/105
==> centos7_server:  
==> centos7_server:   Verifying  : 1398866025:rudder-agent-4.0.4.rc1.git201703220447-1.EL    28/105
==> centos7_server:  
==> centos7_server:   Verifying  : httpd-tools-2.4.6-45.el7.centos.x86_64                    29/105
==> centos7_server:  
==> centos7_server:   Verifying  : systemd-219-30.el7_3.7.x86_64                             30/105
==> centos7_server:  
==> centos7_server:   Verifying  : 1398866025:rudder-webapp-4.0.4.rc1.git201703220317-1.E    31/105
==> centos7_server:  
==> centos7_server:   Verifying  : libselinux-2.5-6.el7.x86_64                               32/105
==> centos7_server:  
==> centos7_server:   Verifying  : 1398866025:rudder-inventory-ldap-4.0.4.rc1.git20170322    33/105
==> centos7_server:  
==> centos7_server:   Verifying  : libXi-1.7.4-2.el7.x86_64                                  34/105
==> centos7_server:  
==> centos7_server:   Verifying  : 1398866025:rudder-jetty-4.0.4.rc1.git201703220317-1.EL    35/105
==> centos7_server:  
==> centos7_server:   Verifying  : audit-libs-python-2.6.5-3.el7_3.1.x86_64                  36/105
==> centos7_server:  
==> centos7_server:   Verifying  : postgresql-9.2.18-1.el7.x86_64                            37/105
==> centos7_server:  
==> centos7_server:   Verifying  : 1398866025:ncf-api-virtualenv-4.0.4.rc1.git20170322031    38/105
==> centos7_server:  
==> centos7_server:   Verifying  : libX11-common-1.6.3-3.el7.noarch                          39/105
==> centos7_server:  
==> centos7_server:   Verifying  : fontconfig-2.10.95-10.el7.x86_64                          40/105
==> centos7_server:  
==> centos7_server:   Verifying  : checkpolicy-2.5-4.el7.x86_64                              41/105
==> centos7_server:  
==> centos7_server:   Verifying  : 1:mod_ssl-2.4.6-45.el7.centos.x86_64                      42/105
==> centos7_server:  
==> centos7_server:   Verifying  : 1398866025:ncf-1.0.0.201703220427-1.EL.7.noarch           43/105
==> centos7_server:  
==> centos7_server:   Verifying  : nspr-4.13.1-1.0.el7_3.x86_64                              44/105
==> centos7_server:  
==> centos7_server:   Verifying  : libjpeg-turbo-1.2.90-5.el7.x86_64                         45/105
==> centos7_server:  
==> centos7_server:   Verifying  : mailcap-2.1.41-2.el7.noarch                               46/105
==> centos7_server:  
==> centos7_server:   Verifying  : javapackages-tools-3.4.1-11.el7.noarch                    47/105
==> centos7_server:  
==> centos7_server:   Verifying  : libselinux-python-2.5-6.el7.x86_64                        48/105
==> centos7_server:  
==> centos7_server:   Verifying  : 1:java-1.8.0-openjdk-headless-1.8.0.121-0.b13.el7_3.x8    49/105
==> centos7_server:  
==> centos7_server:   Verifying  : fontpackages-filesystem-1.44-8.el7.noarch                 50/105
==> centos7_server:  
==> centos7_server:   Verifying  : ttmkfdir-3.0.9-42.el7.x86_64                              51/105
==> centos7_server:  
==> centos7_server:   Verifying  : selinux-policy-targeted-3.13.1-102.el7_3.15.noarch        52/105
==> centos7_server:  
==> centos7_server:   Verifying  : policycoreutils-2.5-11.el7_3.x86_64                       53/105
==> centos7_server:  
==> centos7_server:   Verifying  : libXrender-0.9.8-2.1.el7.x86_64                           54/105
==> centos7_server:  
==> centos7_server:   Verifying  : tzdata-java-2017a-1.el7.noarch                            55/105
==> centos7_server:  
==> centos7_server:   Verifying  : libtool-ltdl-2.4.2-21.el7_2.x86_64                        56/105
==> centos7_server:  
==> centos7_server:   Verifying  : libxslt-1.1.28-5.el7.x86_64                               57/105
==> centos7_server:  
==> centos7_server:   Verifying  : libICE-1.0.9-2.el7.x86_64                                 58/105
==> centos7_server:  
==> centos7_server:   Verifying  : 1398866025:rudder-techniques-4.0.4.rc1.git201703220317    59/105
==> centos7_server:  
==> centos7_server:   Verifying  : libSM-1.2.2-2.el7.x86_64                                  60/105
==> centos7_server:  
==> centos7_server:   Verifying  : libfontenc-1.1.2-3.el7.x86_64                             61/105
==> centos7_server:  
==> centos7_server:   Verifying  : postgresql-libs-9.2.18-1.el7.x86_64                       62/105
==> centos7_server:  
==> centos7_server:   Verifying  : audit-libs-2.6.5-3.el7_3.1.x86_64                         63/105
==> centos7_server:  
==> centos7_server:   Verifying  : nss-tools-3.28.2-1.6.el7_3.x86_64                         64/105
==> centos7_server:  
==> centos7_server:   Verifying  : net-tools-2.0-0.17.20131004git.el7.x86_64                 65/105
==> centos7_server:  
==> centos7_server:   Verifying  : 1:java-1.8.0-openjdk-1.8.0.121-0.b13.el7_3.x86_64         66/105
==> centos7_server:  
==> centos7_server:   Verifying  : libgudev1-219-30.el7_3.7.x86_64                           67/105
==> centos7_server:  
==> centos7_server:   Verifying  : libselinux-utils-2.5-6.el7.x86_64                         68/105
==> centos7_server:  
==> centos7_server:   Verifying  : chkconfig-1.7.2-1.el7.x86_64                              69/105
==> centos7_server:  
==> centos7_server:   Verifying  : apr-1.4.8-3.el7.x86_64                                    70/105
==> centos7_server:  
==> centos7_server:   Verifying  : 1398866025:rudder-server-root-4.0.4.rc1.git20170322031    71/105
==> centos7_server:  
==> centos7_server:   Verifying  : nss-3.28.2-1.6.el7_3.x86_64                               72/105
==> centos7_server:  
==> centos7_server:   Verifying  : httpd-2.4.6-45.el7.centos.x86_64                          73/105
==> centos7_server:  
==> centos7_server:   Verifying  : copy-jdk-configs-1.2-1.el7.noarch                         74/105
==> centos7_server:  
==> centos7_server:   Verifying  : selinux-policy-3.13.1-102.el7_3.15.noarch                 75/105
==> centos7_server:  
==> centos7_server:   Verifying  : systemd-sysv-219-30.el7_3.7.x86_64                        76/105
==> centos7_server:  
==> centos7_server:   Verifying  : xorg-x11-fonts-Type1-7.5-9.el7.noarch                     77/105
==> centos7_server:  
==> centos7_server:   Verifying  : libsemanage-2.5-5.1.el7_3.x86_64                          78/105
==> centos7_server:  
==> centos7_server:   Verifying  : openldap-2.4.40-13.el7.x86_64                             79/105
==> centos7_server:  
==> centos7_server:   Verifying  : libXfont-1.5.1-2.el7.x86_64                               80/105
==> centos7_server:  
==> centos7_server:   Verifying  : libsemanage-python-2.5-5.1.el7_3.x86_64                   81/105
==> centos7_server:  
==> centos7_server:   Verifying  : openldap-clients-2.4.40-13.el7.x86_64                     82/105
==> centos7_server:  
==> centos7_server:   Verifying  : setools-libs-3.3.8-1.1.el7.x86_64                         83/105
==> centos7_server:  
==> centos7_server:   Verifying  : nspr-4.11.0-1.el7_2.x86_64                                84/105
==> centos7_server:  
==> centos7_server:   Verifying  : rsyslog-7.4.7-12.el7.x86_64                               85/105
==> centos7_server:  
==> centos7_server:   Verifying  : nss-util-3.21.0-2.2.el7_2.x86_64                          86/105
==> centos7_server:  
==> centos7_server:   Verifying  : policycoreutils-2.2.5-20.el7.x86_64                       87/105
==> centos7_server:  
==> centos7_server:   Verifying  : libselinux-python-2.2.2-6.el7.x86_64                      88/105
==> centos7_server:  
==> centos7_server:   Verifying  : audit-2.4.1-5.el7.x86_64                                  89/105
==> centos7_server:  
==> centos7_server:   Verifying  : libselinux-2.2.2-6.el7.x86_64                             90/105
==> centos7_server:  
==> centos7_server:   Verifying  : libsemanage-2.1.10-18.el7.x86_64                          91/105
==> centos7_server:  
==> centos7_server:   Verifying  : openldap-2.4.40-9.el7_2.x86_64                            92/105
==> centos7_server:  
==> centos7_server:   Verifying  : systemd-libs-219-19.el7_2.11.x86_64                       93/105
==> centos7_server:  
==> centos7_server:   Verifying  : libselinux-utils-2.2.2-6.el7.x86_64                       94/105
==> centos7_server:  
==> centos7_server:   Verifying  : systemd-sysv-219-19.el7_2.11.x86_64                       95/105
==> centos7_server:  
==> centos7_server:   Verifying  : nss-tools-3.21.0-9.el7_2.x86_64                           96/105
==> centos7_server:  
==> centos7_server:   Verifying  : libgudev1-219-19.el7_2.11.x86_64                          97/105
==> centos7_server:  
==> centos7_server:   Verifying  : selinux-policy-3.13.1-60.el7_2.7.noarch                   98/105
==> centos7_server:  
==> centos7_server:   Verifying  : chkconfig-1.3.61-5.el7_2.1.x86_64                         99/105
==> centos7_server:  
==> centos7_server:   Verifying  : systemd-219-19.el7_2.11.x86_64                           100/105
==> centos7_server:  
==> centos7_server:   Verifying  : audit-libs-2.4.1-5.el7.x86_64                            101/105
==> centos7_server:  
==> centos7_server:   Verifying  : selinux-policy-targeted-3.13.1-60.el7_2.7.noarch         102/105
==> centos7_server:  
==> centos7_server:   Verifying  : nss-3.21.0-9.el7_2.x86_64                                103/105
==> centos7_server:  
==> centos7_server:   Verifying  : nss-sysinit-3.21.0-9.el7_2.x86_64                        104/105
==> centos7_server:  
==> centos7_server:   Verifying  : libsepol-2.1.9-3.el7.x86_64                              105/105
==> centos7_server:  
==> centos7_server: 
==> centos7_server: Installed:
==> centos7_server:   rudder-server-root.noarch 1398866025:4.0.4.rc1.git201703220317-1.EL.7         
==> centos7_server: 
==> centos7_server: Dependency Installed:
==> centos7_server:   apr.x86_64 0:1.4.8-3.el7                                                      
==> centos7_server:   apr-util.x86_64 0:1.5.2-6.el7                                                 
==> centos7_server:   audit-libs-python.x86_64 0:2.6.5-3.el7_3.1                                    
==> centos7_server:   checkpolicy.x86_64 0:2.5-4.el7                                                
==> centos7_server:   copy-jdk-configs.noarch 0:1.2-1.el7                                           
==> centos7_server:   fontconfig.x86_64 0:2.10.95-10.el7                                            
==> centos7_server:   fontpackages-filesystem.noarch 0:1.44-8.el7                                   
==> centos7_server:   giflib.x86_64 0:4.1.6-9.el7                                                   
==> centos7_server:   httpd.x86_64 0:2.4.6-45.el7.centos                                            
==> centos7_server:   httpd-tools.x86_64 0:2.4.6-45.el7.centos                                      
==> centos7_server:   java-1.8.0-openjdk.x86_64 1:1.8.0.121-0.b13.el7_3                             
==> centos7_server:   java-1.8.0-openjdk-headless.x86_64 1:1.8.0.121-0.b13.el7_3                    
==> centos7_server:   javapackages-tools.noarch 0:3.4.1-11.el7                                      
==> centos7_server:   libICE.x86_64 0:1.0.9-2.el7                                                   
==> centos7_server:   libSM.x86_64 0:1.2.2-2.el7                                                    
==> centos7_server:   libX11.x86_64 0:1.6.3-3.el7                                                   
==> centos7_server:   libX11-common.noarch 0:1.6.3-3.el7                                            
==> centos7_server:   libXau.x86_64 0:1.0.8-2.1.el7                                                 
==> centos7_server:   libXcomposite.x86_64 0:0.4.4-4.1.el7                                          
==> centos7_server:   libXext.x86_64 0:1.3.3-3.el7                                                  
==> centos7_server:   libXfont.x86_64 0:1.5.1-2.el7                                                 
==> centos7_server:   libXi.x86_64 0:1.7.4-2.el7                                                    
==> centos7_server:   libXrender.x86_64 0:0.9.8-2.1.el7                                             
==> centos7_server:   libXtst.x86_64 0:1.2.2-2.1.el7                                                
==> centos7_server:   libcgroup.x86_64 0:0.41-11.el7                                                
==> centos7_server:   libfontenc.x86_64 0:1.1.2-3.el7                                               
==> centos7_server:   libjpeg-turbo.x86_64 0:1.2.90-5.el7                                           
==> centos7_server:   libpng.x86_64 2:1.5.13-7.el7_2                                                
==> centos7_server:   libsemanage-python.x86_64 0:2.5-5.1.el7_3                                     
==> centos7_server:   libtool-ltdl.x86_64 0:2.4.2-21.el7_2                                          
==> centos7_server:   libxcb.x86_64 0:1.11-4.el7                                                    
==> centos7_server:   libxslt.x86_64 0:1.1.28-5.el7                                                 
==> centos7_server:   lksctp-tools.x86_64 0:1.0.17-2.el7                                            
==> centos7_server:   mailcap.noarch 0:2.1.41-2.el7                                                 
==> centos7_server:   mod_ssl.x86_64 1:2.4.6-45.el7.centos                                          
==> centos7_server:   mod_wsgi.x86_64 0:3.4-12.el7_0                                                
==> centos7_server:   ncf.noarch 1398866025:1.0.0.201703220427-1.EL.7                               
==> centos7_server:   ncf-api-virtualenv.noarch 1398866025:4.0.4.rc1.git201703220317-1.EL.7         
==> centos7_server:   net-tools.x86_64 0:2.0-0.17.20131004git.el7                                   
==> centos7_server:   openldap-clients.x86_64 0:2.4.40-13.el7                                       
==> centos7_server:   policycoreutils-python.x86_64 0:2.5-11.el7_3                                  
==> centos7_server:   postgresql.x86_64 0:9.2.18-1.el7                                              
==> centos7_server:   postgresql-libs.x86_64 0:9.2.18-1.el7                                         
==> centos7_server:   postgresql-server.x86_64 0:9.2.18-1.el7                                       
==> centos7_server:   python-IPy.noarch 0:0.75-6.el7                                                
==> centos7_server:   python-javapackages.noarch 0:3.4.1-11.el7                                     
==> centos7_server:   python-lxml.x86_64 0:3.2.1-4.el7                                              
==> centos7_server:   rsyslog-pgsql.x86_64 0:7.4.7-16.el7                                           
==> centos7_server:   rudder-agent.i686 1398866025:4.0.4.rc1.git201703220447-1.EL.7                 
==> centos7_server:   rudder-inventory-endpoint.noarch 1398866025:4.0.4.rc1.git201703220317-1.EL.7  
==> centos7_server:   rudder-inventory-ldap.x86_64 1398866025:4.0.4.rc1.git201703220317-1.EL.7      
==> centos7_server:   rudder-jetty.noarch 1398866025:4.0.4.rc1.git201703220317-1.EL.7               
==> centos7_server:   rudder-reports.noarch 1398866025:4.0.4.rc1.git201703220317-1.EL.7             
==> centos7_server:   rudder-techniques.noarch 1398866025:4.0.4.rc1.git201703220317-1.EL.7          
==> centos7_server:   rudder-webapp.noarch 1398866025:4.0.4.rc1.git201703220317-1.EL.7              
==> centos7_server:   setools-libs.x86_64 0:3.3.8-1.1.el7                                           
==> centos7_server:   ttmkfdir.x86_64 0:3.0.9-42.el7                                                
==> centos7_server:   tzdata-java.noarch 0:2017a-1.el7                                              
==> centos7_server:   xorg-x11-font-utils.x86_64 1:7.5-20.el7                                       
==> centos7_server:   xorg-x11-fonts-Type1.noarch 0:7.5-9.el7                                       
==> centos7_server: 
==> centos7_server: Updated:
==> centos7_server:   selinux-policy-targeted.noarch 0:3.13.1-102.el7_3.15                          
==> centos7_server:   systemd.x86_64 0:219-30.el7_3.7                                               
==> centos7_server: 
==> centos7_server: Dependency Updated:
==> centos7_server:   audit.x86_64 0:2.6.5-3.el7_3.1                                                
==> centos7_server:   audit-libs.x86_64 0:2.6.5-3.el7_3.1                                           
==> centos7_server:   chkconfig.x86_64 0:1.7.2-1.el7                                                
==> centos7_server:   libgudev1.x86_64 0:219-30.el7_3.7                                             
==> centos7_server:   libselinux.x86_64 0:2.5-6.el7                                                 
==> centos7_server:   libselinux-python.x86_64 0:2.5-6.el7                                          
==> centos7_server:   libselinux-utils.x86_64 0:2.5-6.el7                                           
==> centos7_server:   libsemanage.x86_64 0:2.5-5.1.el7_3                                            
==> centos7_server:   libsepol.x86_64 0:2.5-6.el7                                                   
==> centos7_server:   nspr.x86_64 0:4.13.1-1.0.el7_3                                                
==> centos7_server:   nss.x86_64 0:3.28.2-1.6.el7_3                                                 
==> centos7_server:   nss-sysinit.x86_64 0:3.28.2-1.6.el7_3                                         
==> centos7_server:   nss-tools.x86_64 0:3.28.2-1.6.el7_3                                           
==> centos7_server:   nss-util.x86_64 0:3.28.2-1.1.el7_3                                            
==> centos7_server:   openldap.x86_64 0:2.4.40-13.el7                                               
==> centos7_server:   policycoreutils.x86_64 0:2.5-11.el7_3                                         
==> centos7_server:   rsyslog.x86_64 0:7.4.7-16.el7                                                 
==> centos7_server:   selinux-policy.noarch 0:3.13.1-102.el7_3.15                                   
==> centos7_server:   systemd-libs.x86_64 0:219-30.el7_3.7                                          
==> centos7_server:   systemd-sysv.x86_64 0:219-30.el7_3.7                                          
==> centos7_server: Complete!
==> centos7_server: Running rudder-init.sh...
==> centos7_server: Done.

#12 Updated by Vincent MEMBRÉ 8 months ago

  • Target version changed from 4.1.0 to 3.1.19

#13 Updated by Benoît PECCATTE 8 months ago

  • Related to deleted (Bug #10118: Selinux Policy may not be correctly applied if selinux packages are updated during install)

#14 Updated by Benoît PECCATTE 8 months ago

  • Priority set to 78

#15 Updated by Vincent MEMBRÉ 7 months ago

  • Status changed from Pending release to Released

This bug has been fixed in Rudder 3.1.19, 4.0.4 and 4.1.1 which were released today.

Also available in: Atom PDF