Project

General

Profile

User story #10314

Document remote-run exec compatibility

Added by Nicolas CHARLES over 1 year ago. Updated 8 months ago.

Status:
New
Priority:
N/A
Assignee:
-
Category:
Agent
Target version (plugin):
Suggestion strength:
User visibility:
Effort required:
Pull Request:

Description

Remote running a 4.0 node fails, as command is not valid

root@agent1:/home/vagrant# /opt/rudder/bin/rudder agent run -uR -I -Dcfruncommand
Rudder agent 4.0.4.rc1.git201702280322 (CFEngine Core 3.7.4)
Node uuid: e04cdc24-2180-4d2e-b334-0445a13a3a45
ok: Rudder agent promises were updated.

remote running a 3.1 node fails, as command /opt/rudder/bin/rudder agent run -uR -I -Dcfruncommand --inform is not valid

root@agent2:/home/vagrant# /opt/rudder/bin/rudder agent run -uR -Dcfruncommand --inform
/opt/rudder/share/commands/agent-run : option non permise -- u
/opt/rudder/share/commands/agent-run : option non permise -- -
/opt/rudder/share/commands/agent-run : option non permise -- n
/opt/rudder/share/commands/agent-run : option non permise -- o
Rudder agent 3.1.19.rc1.git201702210714 (CFEngine Core 3.6.5)
Node uuid: 791a6ebe-cfb1-4f54-b9a2-48ca162f64b6
2017-02-28T12:38:05+0000    error: Remote execution cannot ignore lock

Option "-Dcfruncommand" is not accepted by agent in 3.1 and 4.0 (but it is ok in 4.1)


Related issues

Related to Rudder - Bug #10185: Remote-run exec for root fail with "rudder agent was interrupted"Released

History

#1 Updated by Nicolas CHARLES over 1 year ago

  • Related to Bug #10185: Remote-run exec for root fail with "rudder agent was interrupted" added

#2 Updated by Benoît PECCATTE over 1 year ago

  • Tracker changed from Bug to User story
  • Subject changed from Remote-run exec fails with a 4.1 server and a 4.0 or 3.1 node to Document remote-run exec compatibility

#3 Updated by Vincent MEMBRÉ over 1 year ago

  • Target version changed from 3.1.19 to 3.1.20

#4 Updated by Vincent MEMBRÉ over 1 year ago

  • Target version changed from 3.1.20 to 3.1.21

#5 Updated by Vincent MEMBRÉ over 1 year ago

  • Target version changed from 3.1.21 to 3.1.22

#6 Updated by Vincent MEMBRÉ about 1 year ago

  • Target version changed from 3.1.22 to 3.1.23

#7 Updated by Vincent MEMBRÉ about 1 year ago

  • Target version changed from 3.1.23 to 3.1.24

#8 Updated by Vincent MEMBRÉ 12 months ago

  • Target version changed from 3.1.24 to 3.1.25

#9 Updated by Vincent MEMBRÉ 11 months ago

  • Target version changed from 3.1.25 to 387

#10 Updated by Vincent MEMBRÉ 10 months ago

  • Target version changed from 387 to 4.1.10

#11 Updated by Benoît PECCATTE 8 months ago

  • Target version changed from 4.1.10 to Ideas (not version specific)

Also available in: Atom PDF