Project

General

Profile

Architecture #10032

Architecture #9917: Requires Java8 (jdk8) for Rudder 4.1

Architecture #9918: Update maven compilation target to java8 in rudder-paren-pom

Update dependencies to work with Java 8

Added by François ARMAND 11 months ago. Updated 10 months ago.

Status:
Released
Priority:
1
Category:
Architecture - Dependencies
Target version:
Target version (plugin):
Effort required:

Description

Now that we require Java 8, we need to set straight the whole dependencies transitive graphe. Which is a joy with specs2/scalaz/scalaz-stream/doobie/etc.


Subtasks

Bug #10042: The build is broken since dependencies updateReleasedVincent MEMBRÉ

Associated revisions

Revision 57dcd66c
Added by François ARMAND 11 months ago

Fixes #10032: Update dependencies to work with Java 8

History

#1 Updated by François ARMAND 11 months ago

  • Status changed from In progress to Pending technical review
  • Assignee changed from François ARMAND to Vincent MEMBRÉ
  • Pull Request set to https://github.com/Normation/rudder-parent-pom/pull/34

#2 Updated by François ARMAND 11 months ago

  • Status changed from Pending technical review to Pending release
  • % Done changed from 0 to 100

#3 Updated by Vincent MEMBRÉ 10 months ago

  • Status changed from Pending release to Released

This bug has been fixed in Rudder 4.1.0 which was released today.

Also available in: Atom PDF