Following commands are executed as the root user.

Add the Rudder packages repository:

  • On a SLES 11 system:
zypper ar -n "Rudder SLES repository" http://www.rudder-project.org/rpm-4.2/SLES_11_SP1/ Rudder
  • On a SLES 10 system:
zypper sa "http://www.rudder-project.org/rpm-4.2/SLES_10_SP3/" Rudder

Update your local package database to retrieve the list of packages available on our repository:

zypper ref

For Rudder Server, upgrade all the packages associated to rudder-server-root:

zypper update "rudder-*" "ncf*"

SLES 11 pre SP4 uses PostgreSQL 8.x by default, which is not recommended for Rudder and will cause serious performance degradation, and requires much more disk space in the long run.

Rudder 4.0 is tested for PostgreSQL 9.2 and higher. It still works with version 8.4 or 9.1, but not warranties are made that this will hold in the future. It is really recommanded to migrate to PostgreSQL 9.2 at least.

Please look at Install Rudder Root server on SLES for details.


Rudder 4.1 requires Java RE version 8 or more, which is not packaged be default on SLES 11 On this platform, prior to upgrade Rudder, you will need to install Java RE 8, either from Oracle site https://www.java.com or through any other means of your choice

and after the upgrade of these packages, restart jetty to apply the changes on the Web application:

service rudder-jetty restart

For Rudder Agent, upgrade the rudder-agent package:

zypper update rudder-agent

You can now upgrade your local techniques.