Naming convention

  • The name of bundle and classes should be written with underscore (i.e: this_is_a_good_example) instead of CamelCase (i.e: ThisIsABadExample)
  • All variable, class and bundle names should be prefixed by "rudder_"
  • The bundle entry point for the Technique should be named rudder_<name_of_the_technique>
  • The bundles which makes all the actions should be suffixed by a meaningful name ( "rudder_<name_of_the_Technique>_installation", "rudder_<name_of_the_Technique>_configuration", "rudder_<name_of_the_Technique>_reporting", ..). This rule applies even if there is only one bundle
  • The prefix of classes should all be "rudder_<name of the Technique>_"
  • The classes defined as an outcome should be named:
  • rudder_<name of the Technique>_<action>_kept
  • rudder_<name of the Technique>_<action>_repaired
  • rudder_<name of the Technique>_<action>_failed
  • rudder_<name of the Technique>_<action>_denied
  • rudder_<name of the Technique>_<action>_timeout
  • rudder_<name of the Technique>_<action>_error (error include failed, denied and timeout)
  • The name of the bodies written in the Rudder Library should be prefixed: rudder_common_