Bug #2264

When using the webapp through port forwarding, the css are not loaded

Added by Nicolas CHARLES over 2 years ago. Updated almost 2 years ago.

Status:Rejected Start date:2012-02-09
Priority:N/A Due date:
Assignee:- % Done:

0%

Category:Webapp - Display, home page
Target version:2.3.9
Needs translating:No Pull Request:

Description

As we've been told :
I forwarded port 9000 of my PC to port 80 inside the vm, but then I had no css - I set the FQDN to localhost, so the css links are http://localhost/something.css - wouldn't it be better to use /something.css instead?

We need to find a solution for this (look at Apache or the code, or both ?)


Related issues

related to Rudder - Bug #2282: One can not omit the configuration of a base URL in rudde... Released 2012-02-15

History

#1 Updated by Nicolas CHARLES over 2 years ago

<Ronny1> it was not a big problem because I changed the forwarding so that it is pc:80 -> vm:80 instead of pc:9000 -> vm:80 and then it worked

#2 Updated by Matthieu CERDA over 2 years ago

As far as I can tell, this configuration property might help :

##
# Application information
##
#define that property if you are behind a proxy
#or anything that make the URL served by the
#servlet container be different than the public one
#note: if defined, must not end with /
#let blank to use default value
base.url=http://foo.bar.baz/rudder

As seen in the explicative comment, one might maybe comment it so you do not have an enforced FQDN for the CSS. I'll try this.

#3 Updated by Matthieu CERDA over 2 years ago

  • Status changed from New to Discussion

#4 Updated by Matthieu CERDA over 2 years ago

OK, it failed. I opened another issue to track this at #2282

#5 Updated by Jonathan CLARKE over 2 years ago

  • Target version changed from 2.4.0~alpha6 to 2.4.0~alpha7

#6 Updated by Jonathan CLARKE about 2 years ago

  • Target version changed from 2.4.0~alpha7 to 2.3.8

#7 Updated by Jonathan CLARKE about 2 years ago

  • Target version changed from 2.3.8 to 2.3.9

#8 Updated by Jonathan CLARKE almost 2 years ago

  • Category changed from 11 to Webapp - Display, home page

#9 Updated by Jonathan CLARKE almost 2 years ago

  • Status changed from Discussion to Rejected
  • 2 set to 0

This should be fixed by #2282, but only for Rudder 2.4.x. This won't be fixed in Rudder 2.3.x.

Also available in: Atom PDF