Bug #2263

After rudder-init'ing an existing rudder root server, which had archives of old PIs and PT libs, I get only two enabled PTs and some errors in the logs

Added by Matthieu CERDA almost 3 years ago. Updated over 2 years ago.

Status:Rejected Start date:2012-02-09
Priority:2 Due date:
Assignee:Matthieu CERDA % Done:

0%

Category:Architecture - Refactoring
Target version:2.4.0~alpha6
Needs translating:No Pull Request:

Description

After rudder-init'ing an existing rudder root server, which had archives of old PIs and PT libs, I get only two enabled PTs and some errors in the logs:

Log:

15:10:31.300 [main]            INFO  b.l.c.CheckInitUserTemplateLibrary - The user policy template library is not marked as being initialized: adding all policies from reference library...
15:10:40.551 [pool-3-thread-8] INFO  c.n.p.a.service.AgregationService - Finished the agregation in 16858 millisec
15:10:41.396 [main]            WARN  b.l.c.CheckInitUserTemplateLibrary - Some error where encountered during the initialization of the user library 
 -> Error processing /applications 
 -> Error processing /systemSettings 
 -> Error processing /fileDistribution 
 -> Error processing /fileConfiguration 
 -> Error when adding category 'userlib_fileConfiguration' to user library parent category 'UserPolicyTemplateLibraryRoot' 
 -> Auto-archive git failure: not found in git added files: policy-library/userlib_fileConfiguration/category.xml
15:10:42.253 [main]            INFO  bootstrap.liftweb.Boot - Initializing plugin 'Advanced Reporting' [com.normation.plugins.advancedreports.AdvancedReportingPluginDef]
15:10:42.253 [main]            INFO  c.n.p.a.AdvancedReportingPluginDef - loading advancedreporting plugin

History

#1 Updated by Matthieu CERDA almost 3 years ago

  • Status changed from New to Discussion
  • Assignee set to Jonathan CLARKE

It looks like it was a collision of uncommited PT's in the /configuration-repository. Should we consider this as a bug or as a side effect of a broken GIT tree ?

#2 Updated by Jonathan CLARKE almost 3 years ago

  • Target version changed from 2.4.0~alpha5 to 2.4.0~alpha6

Matthieu CERDA wrote:

It looks like it was a collision of uncommited PT's in the /configuration-repository. Should we consider this as a bug or as a side effect of a broken GIT tree ?

I dunno: it depends what the situation was, what you expected to happen, and what really happened. Could you detail this please?

#3 Updated by Matthieu CERDA over 2 years ago

I think we should close this, i tried to reproduce it and never managed to make it happen again. I suppose that the test orchestrator was a bit confused.

#4 Updated by Jonathan CLARKE over 2 years ago

  • Status changed from Discussion to Rejected
  • Assignee changed from Jonathan CLARKE to Matthieu CERDA

Also available in: Atom PDF