Project

General

Profile

Architecture #1545

Fix hack for rudder-reports SuSE RPM

Added by Nicolas PERRON over 5 years ago. Updated about 2 months ago.

Status:
Rejected
Priority:
3
Assignee:
-
Category:
Packaging
Start date:
2011-08-02
Due date:
% Done:

0%

Pull Request:

Description

In order to ensure being capable of connecting to postgresql, rudder-reports add 2 lines in the begining of pg_hba.conf and reload postgresql.

The lines need to be correctly placed in the file (somewhere in the middle :)

History

#1 Updated by Jonathan CLARKE over 5 years ago

  • Target version set to Ideas (2.3 specific)

#2 Updated by François ARMAND about 5 years ago

  • Status changed from New to Discussion
  • Target version deleted (Ideas (2.3 specific))

I think that was done recently, no ?

#3 Updated by Jonathan CLARKE about 5 years ago

  • Status changed from Discussion to 2
  • Priority changed from 4 to 3
  • Target version set to 23

François ARMAND wrote:

I think that was done recently, no ?

No, not yet.

#4 Updated by Jonathan CLARKE about 5 years ago

  • Target version changed from 23 to 18

#5 Updated by François ARMAND about 5 years ago

  • Target version changed from 18 to 2.4.0~alpha1

#6 Updated by Jonathan CLARKE about 5 years ago

  • Target version changed from 2.4.0~alpha1 to 2.4.0~alpha2

#7 Updated by Jonathan CLARKE almost 5 years ago

  • Target version changed from 2.4.0~alpha2 to 2.4.0~alpha3

#8 Updated by Jonathan CLARKE almost 5 years ago

  • Target version changed from 2.4.0~alpha3 to 2.4.0~alpha4

#9 Updated by François ARMAND almost 5 years ago

  • Target version changed from 2.4.0~alpha4 to 2.4.0~alpha5

#10 Updated by Jonathan CLARKE almost 5 years ago

  • Target version changed from 2.4.0~alpha5 to 2.4.0~alpha6

#11 Updated by Jonathan CLARKE over 4 years ago

  • Target version changed from 2.4.0~alpha6 to 2.3.8

#12 Updated by Jonathan CLARKE over 4 years ago

  • Target version changed from 2.3.8 to 2.3.9

#13 Updated by Jonathan CLARKE over 4 years ago

  • Target version changed from 2.3.9 to 2.4.0~rc1

#14 Updated by Jonathan CLARKE over 4 years ago

  • Target version changed from 2.4.0~rc1 to 2.3.9

#15 Updated by Nicolas PERRON about 4 years ago

  • Status changed from 2 to Discussion
  • Assignee set to Jonathan CLARKE

I suppose we should "fix" the package rudder-reports with using the same implementation with CFEngine instead of packaging ?

#16 Updated by Nicolas PERRON about 4 years ago

  • Target version changed from 2.3.9 to 2.3.10

#17 Updated by François ARMAND about 4 years ago

  • Tracker changed from Bug to Architecture
  • Description updated (diff)
  • Status changed from Discussion to 8
  • Assignee changed from Jonathan CLARKE to Nicolas PERRON
  • Target version changed from 2.3.10 to Ideas (not version specific)

This is clearly not a bug, and will be added in some next version.

#18 Updated by Jonathan CLARKE about 4 years ago

Nicolas PERRON wrote:

I suppose we should "fix" the package rudder-reports with using the same implementation with CFEngine instead of packaging ?

Yes, this is the right approach.

#19 Updated by Nicolas PERRON almost 4 years ago

  • Project changed from Rudder to packages
  • Category deleted (11)

#20 Updated by Nicolas PERRON over 3 years ago

  • Assignee deleted (Nicolas PERRON)

I've never worked on it

#21 Updated by Benoît PECCATTE almost 2 years ago

  • Project changed from packages to Rudder
  • Category set to Packaging

#22 Updated by Benoît PECCATTE over 1 year ago

  • Status changed from 8 to New

#23 Updated by Benoît PECCATTE about 2 months ago

I suppose we should "fix" the package rudder-reports with using the same implementation with CFEngine instead of packaging ?

I do not understand this sentence at all.

Moreover the issue description doesn't match reality :

In order to ensure being capable of connecting to postgresql, rudder-reports add 2 lines in the begining of pg_hba.conf and reload postgresql." 

rudder-reports does nothing, it is postgres-check in system technique that does this.

The lines need to be correctly placed in the file (somewhere in the middle :)

Since it is already done, why should they be placed again in the file ?

#24 Updated by Benoît PECCATTE about 2 months ago

  • Status changed from New to Rejected

This seems to be done in #2207

Also available in: Atom PDF